Hummer club - Page 12





Page 12 of 24 FirstFirst ... 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 ... LastLast
Results 221 to 240 of 462

Thread: Hummer club

  1. #221
    Join Date
    Sep 2011
    Location
    Johannesburg
    Age
    41
    Posts
    762
    Thanked: 1

    Default

    Haha my father has owed his H3 alpha alsmot as long as yours . he got a yellow v8 2009 model lux with 15000km on the clock (very lucky)

    Please remember Hennops has braai facilities but no tables or chairs so bring your own.

    also with this rain its going to be very exciting the track wil bring back memories of my trip through Lesotho.
    One Life Live it

    Current: Land Rover Discovery 3 V8 HSE

    upgrade
    8mm steel bush plate
    Front Runner discreet winch bracket
    T-MAX 9500 winch
    Front Runner roof rack
    Front Runner ladder


    Hero : 3.7L 5s H3 Hummer Auto
    upgrades
    T-max winch 9500
    Rancho RX9000 XL shocks
    Rancho Myride
    2nd stage viper exhaust system
    Safari Snorkel
    Front Runner roof rack
    Cooper Discoverer STT

  2. #222
    Join Date
    Oct 2012
    Location
    Rustenburg
    Age
    34
    Posts
    331
    Thanked: 0

    Default

    Hi Guys, I'm in. I missed the first one we planned and hope I will make this one.

    I really don't know what is going on with my truck. I replaced the oil, oil filters, oil pump, oil switch, termometer, and I went to pick it up on Saturday. Drove like a dream (better than before).

    I did about 186 km with no hassels, 120km/h, speed control on, uphill, downhill, didn't even gear back. When I stopped at the house in Rustenburg, at that exact moment, it gave me an "oil" alarm again.

    I really don't know what to do. I don't know if the people working on our trucks are competent or not......

    I opened the hood this morning an saw that the pully they replaced on the pump is bend......

    I really want to be there on Sunday, I'm planning everything around it, but I can't find one person who knows what he is doing.....

    So, I am trying my best to get it sorted before the weekend. Hopefully I will see you all there.
    HUMMER, Like nothing else....

    Current: 3.7L 5s H3 Hummer Auto
    Previous: 3.0 4x4 Mazda BT50

  3. #223
    Join Date
    Sep 2011
    Location
    Johannesburg
    Age
    41
    Posts
    762
    Thanked: 1

    Default

    The Gm Dealer at fourways have always done fantastic services on my Hummer the Gm in Bruma on the other had has also trained personal working there maybe the guys are one leave but you must hold them to it as the consumer act will be on your side. I hope you there even if you dont do the track and accompany another driver
    One Life Live it

    Current: Land Rover Discovery 3 V8 HSE

    upgrade
    8mm steel bush plate
    Front Runner discreet winch bracket
    T-MAX 9500 winch
    Front Runner roof rack
    Front Runner ladder


    Hero : 3.7L 5s H3 Hummer Auto
    upgrades
    T-max winch 9500
    Rancho RX9000 XL shocks
    Rancho Myride
    2nd stage viper exhaust system
    Safari Snorkel
    Front Runner roof rack
    Cooper Discoverer STT

  4. #224
    Join Date
    Oct 2012
    Location
    Rustenburg
    Age
    34
    Posts
    331
    Thanked: 0

    Default

    Thanks frozen. I totally agree. Spoke to their Worshop Manager. I have to go to j burg tomorrow for business, will drop it off the afternoon and he will organize me another car. Then on wednesday morning I'm flying to the North Cape and wednesday night back. They will try to get it sorted during wednesday.

    So now I must just hope they do their work properly. I'm going to jump into those poor electrical connections within the next 5 min and do it properly myself......

    Sent from my BlackBerry 9900 using Tapatalk
    HUMMER, Like nothing else....

    Current: 3.7L 5s H3 Hummer Auto
    Previous: 3.0 4x4 Mazda BT50

  5. #225
    Join Date
    Jul 2009
    Location
    -
    Posts
    1,524
    Thanked: 32

    Default

    Eish, hope they get the Hummer sorted, but you can always come and enjoy the day with us without your Hummer but we will support you thru the tough times
    -

  6. #226
    Join Date
    Oct 2012
    Location
    Rustenburg
    Age
    34
    Posts
    331
    Thanked: 0

    Default

    Ha ha. Thanks Sennin.

    Well, I did it. I took the battery out, opened the fuse box, pulled out the elect harness and cut it open. And you guys know what I found, burned wires......

    The old battery leaked and some acid ran out. (For one or another reason I don't know why they install the fuse box next to and lower than the battery. I cleaned and repaired about 9 wires. Wrapped everything up, put every thing back, o, you know what I found, the new battery that the agents installed is too big for the cover. So, I took a saw and cut the handles of, walla, it fits. I replaced the baterry connection properly!!!!! And took it for a spin 10:30 last night. All is well.

    Got up this morning, left home at about 04:00. When I drove into J-burg, the first robot I stop at,....."Oil" alarm. So I said screw this, and pulled away, alarm goes dead. Next robot the same. 3rd robot the same, and then it stopped.



    So, I'm taking him back to GM this afternoon.....R30 000 later and still the same problem. O yes, and the temp stays just above half while I am driving. When I stop, it goes to 3/4 mark......(my guess, the fan doesn't kick in, but what do I know)..

    Sent from my BlackBerry 9900 using Tapatalk
    HUMMER, Like nothing else....

    Current: 3.7L 5s H3 Hummer Auto
    Previous: 3.0 4x4 Mazda BT50

  7. #227
    Join Date
    Jul 2009
    Location
    -
    Posts
    1,524
    Thanked: 32

    Default

    Quote Originally Posted by ZachH3 View Post
    Ha ha. Thanks Sennin.

    Well, I did it. I took the battery out, opened the fuse box, pulled out the elect harness and cut it open. And you guys know what I found, burned wires......

    The old battery leaked and some acid ran out. (For one or another reason I don't know why they install the fuse box next to and lower than the battery. I cleaned and repaired about 9 wires. Wrapped everything up, put every thing back, o, you know what I found, the new battery that the agents installed is too big for the cover. So, I took a saw and cut the handles of, walla, it fits. I replaced the baterry connection properly!!!!! And took it for a spin 10:30 last night. All is well.

    Got up this morning, left home at about 04:00. When I drove into J-burg, the first robot I stop at,....."Oil" alarm. So I said screw this, and pulled away, alarm goes dead. Next robot the same. 3rd robot the same, and then it stopped.



    So, I'm taking him back to GM this afternoon.....R30 000 later and still the same problem. O yes, and the temp stays just above half while I am driving. When I stop, it goes to 3/4 mark......(my guess, the fan doesn't kick in, but what do I know)..

    Sent from my BlackBerry 9900 using Tapatalk
    Eish, this now sounds like a poor connection problem somewhere on the wiring of the sensors perhaps? I know when my 3.7 had the hiccups when going uphill (it would die, bud going downhill no problem) after a month of various technicians end even Bosch getting involveld to test, they finally decided to replace the whole engine wiring harness (R14,500) and then everything was sorted untill I sold the old girl.
    -

  8. #228
    Join Date
    Jun 2012
    Location
    Alberton
    Age
    64
    Posts
    787
    Thanked: 0

    Default

    .............. and here I was braging that Hummers do not have problems (Hummer Minority)
    2010 Hummer H3 5,3 Lux
    2002 Colt DC; - 3,2Lt Triton Conversion - FOR SALE
    Toy's - 2003 Honda Goldwing Trike + Same Bike 2010
    Platkar - 2007 C320 CDI now SWAMBO's

  9. #229
    Join Date
    Sep 2011
    Location
    Johannesburg
    Age
    41
    Posts
    762
    Thanked: 1

    Default

    Quote Originally Posted by ZachH3 View Post
    Ha ha. Thanks Sennin.

    Well, I did it. I took the battery out, opened the fuse box, pulled out the elect harness and cut it open. And you guys know what I found, burned wires......

    The old battery leaked and some acid ran out. (For one or another reason I don't know why they install the fuse box next to and lower than the battery. I cleaned and repaired about 9 wires. Wrapped everything up, put every thing back, o, you know what I found, the new battery that the agents installed is too big for the cover. So, I took a saw and cut the handles of, walla, it fits. I replaced the baterry connection properly!!!!! And took it for a spin 10:30 last night. All is well.

    Got up this morning, left home at about 04:00. When I drove into J-burg, the first robot I stop at,....."Oil" alarm. So I said screw this, and pulled away, alarm goes dead. Next robot the same. 3rd robot the same, and then it stopped.



    So, I'm taking him back to GM this afternoon.....R30 000 later and still the same problem. O yes, and the temp stays just above half while I am driving. When I stop, it goes to 3/4 mark......(my guess, the fan doesn't kick in, but what do I know)..

    Sent from my BlackBerry 9900 using Tapatalk
    Hi
    My H3 runs 3/4 hot for the last year if you turn the Aircon off it drops down to half if you have the aircon on then it goes up to 3/4 but put it on circulate and then it dropes inbetween 1/2 and 3/4.

    the thing with Hummers is it may not even be a fault with the oil sensor I had a traction control failure on my H3 and it turnd out to be the brake light switch on the brake pedal mad hey.
    Last edited by frozen7days; 2012/12/04 at 09:50 AM.
    One Life Live it

    Current: Land Rover Discovery 3 V8 HSE

    upgrade
    8mm steel bush plate
    Front Runner discreet winch bracket
    T-MAX 9500 winch
    Front Runner roof rack
    Front Runner ladder


    Hero : 3.7L 5s H3 Hummer Auto
    upgrades
    T-max winch 9500
    Rancho RX9000 XL shocks
    Rancho Myride
    2nd stage viper exhaust system
    Safari Snorkel
    Front Runner roof rack
    Cooper Discoverer STT

  10. #230
    Join Date
    Oct 2012
    Location
    Rustenburg
    Age
    34
    Posts
    331
    Thanked: 0

    Default

    Ja guys. I don't know anymore. I can really take a lot of trouble but when it gets to my wheels, I loose it completely.

    Well, I spoke with the Manager this time and maybe he knows what to do. Except for the trip the weekend, next weekend we are going on leave. I'm going to Sodwana and then moz in Jan but I can't tow my trailer with the truck if it is not sorted.

    Arggggg, I hate this!!!!! Let's see what happens. Bumble, all things brake man, normally hummers don't but when it does, it huge hassles to get it sorted my friend....

    One thing is a fact, I am not a happy camper at this moment.

    Sent from my BlackBerry 9900 using Tapatalk
    HUMMER, Like nothing else....

    Current: 3.7L 5s H3 Hummer Auto
    Previous: 3.0 4x4 Mazda BT50

  11. #231
    Join Date
    Jul 2012
    Location
    Secunda
    Age
    36
    Posts
    1,099
    Thanked: 8

    Default

    Hey Zach, dunno if your GM engine has this, but I'm guessing it would. After the oil pump is a relief valve. It's a steel ball pushed shut by a spring. When your rpms go up this thing opens to keep the oil pressure roughly steady. Thysleroux's RooiTjiep had the same problem, where some dirt went in here. What happens is upon startup the valve is closed, as you drive under higher rpm it opens and gets stuck, when you stop the oil light comes on/pressure drops, the valve however does close again SLOWLY and all seems fine. If this is your problem DO NOT use your truck man! Thys had his motor sieze up the second time this happened(he was towing a big trailer though).

    Have a read here:

    http://4x4community.co.za/forum/showthread.php?t=126404

    Hope this helps. Cheers!

  12. #232
    Join Date
    Jul 2009
    Location
    -
    Posts
    1,524
    Thanked: 32

    Default

    Here's the layout of the 3.7 engine oil system





    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	3.7 oil.jpg 
Views:	691 
Size:	122.9 KB 
ID:	181499   Click image for larger version. 

Name:	Callout 1.jpg 
Views:	602 
Size:	122.4 KB 
ID:	181500   Click image for larger version. 

Name:	Callout 2.jpg 
Views:	1546 
Size:	180.4 KB 
ID:	181501  
    -

  13. #233
    Join Date
    Jul 2012
    Location
    Secunda
    Age
    36
    Posts
    1,099
    Thanked: 8

    Default

    414, 415, 416. Looks like you can get to it by taking off the front cover(which will probably include stripping out the radiator, grille, bumper etc.). Probably 3 bolts on the sump too. Im guessing that the pump will come off with the cover, best is to spy a workshop manual. It will have the clearances for the pump gears, and these are also quite critical.

    Flushing might help, by moving the dirt(if any) somewhere else. Personally I would drain the oil and bend a piece of wire to 'dig in the dirt' through the drain hole, check for gunk, if it's there, take off the sump and clean it out.

    EDIT: If you take the sump off, also check the oil pickup strainer!
    Last edited by RedneckRampage; 2012/12/04 at 02:49 PM.

  14. #234
    Join Date
    Oct 2012
    Location
    Rustenburg
    Age
    34
    Posts
    331
    Thanked: 0

    Default

    Thanks a lot guys. Make sense. Sounds almost the same as my truck. Will get it checked out asap.

    Sent from my BlackBerry 9900 using Tapatalk
    HUMMER, Like nothing else....

    Current: 3.7L 5s H3 Hummer Auto
    Previous: 3.0 4x4 Mazda BT50

  15. #235
    Join Date
    Sep 2011
    Location
    Johannesburg
    Age
    41
    Posts
    762
    Thanked: 1

    Default

    Quote Originally Posted by ZachH3 View Post
    Thanks a lot guys. Make sense. Sounds almost the same as my truck. Will get it checked out asap.

    Sent from my BlackBerry 9900 using Tapatalk
    any update yet on your Hummer?
    One Life Live it

    Current: Land Rover Discovery 3 V8 HSE

    upgrade
    8mm steel bush plate
    Front Runner discreet winch bracket
    T-MAX 9500 winch
    Front Runner roof rack
    Front Runner ladder


    Hero : 3.7L 5s H3 Hummer Auto
    upgrades
    T-max winch 9500
    Rancho RX9000 XL shocks
    Rancho Myride
    2nd stage viper exhaust system
    Safari Snorkel
    Front Runner roof rack
    Cooper Discoverer STT

  16. #236
    Join Date
    Oct 2012
    Location
    Rustenburg
    Age
    34
    Posts
    331
    Thanked: 0

    Default

    Hi boet. Took it to fourways yesterday afternoon. They don't really know what's going on so now they think it is an elect problem. Will find out tomorrow what's going on and let you guys know. It can't be the fan, its working. They replaced all the other oil components, they took of the thermostat today and re tested the new one.

    Well, they don't know and wanted to test it this afternoon and tomorrow morning. Let's see what they come up with........

    Sent from my BlackBerry 9900 using Tapatalk
    HUMMER, Like nothing else....

    Current: 3.7L 5s H3 Hummer Auto
    Previous: 3.0 4x4 Mazda BT50

  17. #237
    Join Date
    Oct 2011
    Location
    Pretoria
    Age
    33
    Posts
    322
    Thanked: 15

    Default

    Quote Originally Posted by ZachH3 View Post
    Hi boet. Took it to fourways yesterday afternoon. They don't really know what's going on so now they think it is an elect problem. Will find out tomorrow what's going on and let you guys know. It can't be the fan, its working. They replaced all the other oil components, they took of the thermostat today and re tested the new one.

    Well, they don't know and wanted to test it this afternoon and tomorrow morning. Let's see what they come up with........

    Sent from my BlackBerry 9900 using Tapatalk
    Eish, I wish you the best. Hopefully they do find the problem and it might be something the rest of us must check before its to late.
    HUMMER H3 Adventure 3,7L

    Achievement Unlocked: Hang A HUMMER.... Twice
    Achievement Unlocked: Shoot a .50 cal rifle
    Achievement Unlocked: Shoot original AK47


  18. #238
    Join Date
    Oct 2012
    Location
    Rustenburg
    Age
    34
    Posts
    331
    Thanked: 0

    Default

    Will let you guys know exactly what's going on. He he. Hope you guys are ready for that story...... Ha ha ha.

    Sent from my BlackBerry 9900 using Tapatalk
    HUMMER, Like nothing else....

    Current: 3.7L 5s H3 Hummer Auto
    Previous: 3.0 4x4 Mazda BT50

  19. #239
    Join Date
    Jul 2012
    Location
    Secunda
    Age
    36
    Posts
    1,099
    Thanked: 8

    Default

    Will be quite interesting. The Jeep guys here didn't even know of the problem with the 4.7 and 3.7 throwing valve seats! They thaught the cam pulley broke causing a valve to be snapped off and chewing up a piston. I showed the 'head mechanic' a couple of youtube vids and he was stunned What did they do? Replace the engine! They checked afterwards and found nothing wrong except for 2 valve seats thrown... Engine: R90k, Fix thrown seats and replace valves: R3k - 5k! And they didn't even feel bad about it! Fortunately it wasn't my Jeep... 2cents. Good luck, hope they find the problem, and sort it properly.

  20. #240
    Join Date
    Oct 2012
    Location
    Rustenburg
    Age
    34
    Posts
    331
    Thanked: 0

    Default

    These guys just wanne replace replace.... They went through all the wiring from all the sensors and "still" busy testing the turmostat. They going to test the truck at 11:00 and will let me know whats the outcome.

    The only thing I really struggle to understand, is that they bend the one pulley when they changed the oil pump, now they say that didn't remove the pulley when they replaced the pump. Well, to get in there you have to remove all those parts. Secondly they don't know what the problem is but when I told them that I fixed the wiring which their mechanic only closed up, now all of a sudden its wiring problems...

    Incompetence is an understatement. Only thing I can say is that those guys can be glad they don't work for me.
    HUMMER, Like nothing else....

    Current: 3.7L 5s H3 Hummer Auto
    Previous: 3.0 4x4 Mazda BT50

Page 12 of 24 FirstFirst ... 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 ... LastLast

Similar Threads

  1. Fundi Final!!
    By RangeRover in forum 4x4 Trails / Routes / Clubs
    Replies: 38
    Last Post: 2011/09/20, 06:37 AM
  2. Kouga 4x4 club, community project 2010
    By fanie1 in forum Eastern Cape
    Replies: 0
    Last Post: 2010/09/19, 06:43 PM
  3. AAWDC Inter Club Fun Day
    By bushcamp in forum Gauteng
    Replies: 48
    Last Post: 2009/08/25, 02:24 PM
  4. nissan 4x4 club
    By Tal in forum Nissan
    Replies: 0
    Last Post: 2009/02/24, 10:45 PM
  5. Serengeti Briefing- Multi- Motor Club 31-01-2009 Cape Town
    By Ashley in forum Calender & Events
    Replies: 4
    Last Post: 2009/02/06, 04:58 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •