Engel problem?





Results 1 to 4 of 4

Thread: Engel problem?

  1. #1
    Join Date
    Sep 2006
    Location
    Midrand
    Age
    49
    Posts
    2,726

    Default Engel problem?

    Hi all

    My Engel works like a charm on 220V as well as 12V in the car. Recently it has been popping fuses (which I am assuming because of the elcheapo plugs I was using).
    Popping of fuses has stopped since I put proper plugs on. Now it melts the fuse.... Why is that?

    Cheers
    "A turbo: exhaust gasses go into the turbocharger and spin it, witchcraft happens and you go faster "
    By Jeremy Clarkson (I think)

  2. #2
    Join Date
    Nov 2006
    Location
    Hermanus
    Age
    59
    Posts
    1,826

    Default

    The problem can be from both ends. First and cheapest option is to check your 12V supply from the battery. Make sure there are no shorts. Did you fit any power related kit lately? If the supply power is okay, rather take the thing to a repair specialist. I did, R5000 + for a new one is serious money. The termostat started giving problems after jumpstarting another oke and neglected to disconnect the plug.
    FJ Cruiser
    Echo Kavango

  3. #3
    Join Date
    Sep 2006
    Location
    Midrand
    Age
    49
    Posts
    2,726

    Default

    Been thinking.... Does one get "cheap" fuses? The ones I am using now I got for nothing in Pinetown a few weeks back. They look ### and compared to the 35A fuses I got confirm this....

    Any possibility this is my problem?

    Further, if the fridge is faulty, can this happen on the 12V circuit only?

  4. #4
    Join Date
    Sep 2006
    Location
    Kempton Park
    Age
    52
    Posts
    13,855

    Default

    Check for pinched or damaged cables . Always buy good quality.....might not be the problem.
    Turnkey Construction Projects, Commercial, industrial, Domestic
    Importers: Diving gear, Compressed air cylinders for diving and airgun industry, 4x4 equipment.
    Manufacturers: Pofadder Kinetic ropes, Recovery kits, Synthetic winch ropes
    Vehicles: Modifications and installations, Special application vehicles
    Driver training: 4x4, Defensive
    [email protected]
    +27824453301

Similar Threads

  1. WJ 2.7 CRD Maintenance
    By wtrlan in forum Jeep
    Replies: 240
    Last Post: 2018/04/19, 07:20 AM
  2. Quest problem with t4a and streetmaps
    By Johan Barnard in forum GPS & Mapping
    Replies: 17
    Last Post: 2014/01/01, 04:27 PM
  3. Engel not happy running on 220V . Fine on 12V .
    By PGJ in forum Camping, Fridges, Accessories
    Replies: 6
    Last Post: 2011/06/25, 01:53 PM
  4. Ford 2.5tdi problem.
    By DJLSchoemm in forum Ford & Mazda
    Replies: 1
    Last Post: 2011/04/12, 04:44 PM
  5. Toyota Hilux D4D 3.0L D/C 4x2- Handeling Problem
    By NicStix in forum General 4x4 Discussion
    Replies: 2
    Last Post: 2009/07/29, 12:53 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •