Results 1 to 16 of 16
  1. #1
    Join Date
    Mar 2011
    Location
    PE
    Age
    48
    Posts
    5
    Thanked: 0

    Default 4X4 lights always on

    My 4x4 lights worked like it should till I noticed that the switch wires on the back of the box was about to break. I removed the switch and fixed the cable. It then did not work at all. I was told to replace both the gearbox switched which is waht I did. Now my 4x4 lights stay on all the time.

    Any ideas ??

  2. #2
    Join Date
    Jan 2010
    Location
    Centurion
    Age
    43
    Posts
    1,575
    Thanked: 17

    Default

    So the light stays on even when it is not in 4x4 ? What happens if you put it in 4x4 ?
    Eduan Erasmus-Since 1980- 2016 Merc B200 Cdi2012 Scott Aspect 30 2012 Silverback Roadie

  3. #3
    Join Date
    Aug 2009
    Location
    Gezina
    Age
    53
    Posts
    185
    Thanked: 1

    Default

    still a faulty switch, maybe the wrong switch. this one is normally open untill you engage 4x4, the switch closes and the light comes on, the switch may be stuck in the closed circuit position

    paul moult
    2002 landrover discovery 2 td5
    burnco front bumper

  4. #4
    Join Date
    Mar 2011
    Location
    PE
    Age
    48
    Posts
    5
    Thanked: 0

    Default

    engages 4x4 like it should, 4H,4L and my diff lock works as well.

  5. #5
    Join Date
    Mar 2011
    Location
    PE
    Age
    48
    Posts
    5
    Thanked: 0

    Default

    Checked the switches, back one is closed till you engage 4x4 then opens and other one is open all the time. I have checked a buddys colt and the 2 switches are the same.
    Last edited by Coltspider; 2011/03/11 at 12:27 PM.

  6. #6
    Join Date
    May 2010
    Location
    Pretoria East
    Age
    76
    Posts
    47
    Thanked: 0

    Default

    just MTCW my vehicle 2.8tdi indication is ok in 2H but in 4H & 2L 4x4 light continually flashing but undrstand this this should be permanently on in 4H 2L traced problem to the "Freewheel Detection Switch" which some how works in conjunction with the other two switches refered to fitted on the transfercase. My FDS is open in all conditons. In 2H no lindiation but in 4H & 4L the lamp is flashing continually i.e the FDS constantly open circuit. Shorting out this switch produces a flashing 4x4 light in 2H But in 4H /4L is constantly illuminated. The FDS is situateted on top of the synco hub on the drivers side of the front differential. Hope this helps

  7. #7
    Join Date
    Mar 2011
    Location
    PE
    Age
    48
    Posts
    5
    Thanked: 0

    Default 4x4 lights on

    I have replace the switch on the front diff as well. I did notice that if i unplug this switch my light flash. I have also removed the switch and tested it and the switch is working. I have also checked the two vacum switches and they seem to be ok. It is starting to bug me.

  8. #8
    Join Date
    Feb 2011
    Location
    Port Elizabeth
    Age
    40
    Posts
    296
    Thanked: 2

    Default

    I told you take it to Ravens.
    Let them sort it quick for you.
    _______________________
    Colt`s are build to off-road.
    Colt 2.8 TDI Double Cab 4x4 - Sold
    Colt 3.0 V6 Double Cab 4x4 - Sold
    Triton 2.5 DID Double cab 4x4 - Sold
    Pathfinder 2.5 DCI 4x4 - Sold

  9. #9
    Join Date
    Oct 2008
    Location
    Sasolburg
    Age
    45
    Posts
    117
    Thanked: 0

    Default

    I have got almost the same type of problem.
    In normal 2H the 4X4 light started flashing after a heavy rain storm and about a 5km trip on a muddy/sandy road which almost turned into a small river. Before I got to the tar road I disengaged from 4H to 2H and since then the light were flashing.

    It didn't bother much because I thought it was one of the switches that was malfunctioning. I then after about 2 weeks went to go play a bit and then realized that the 4X4 light was illuminated but also looked like there was someting not making propper contact. It stays illuminated with a flicker every now and then and now the Difflock is not engaging/swithing on.

    I took out one of the switches (4X4 Detection switch) on the back of the gearbox and tested it and it seems to work end then not work. I cleaned it and since then the 4X4 light stayed illuminated if 4X4 was engaged (Still flashed though if dissengaged) and difflock still not opperating. I tested the difflock switch which is also still in working condition.

    Everything was working with no hassles till that day. What and where can I look for the problem? Any Ideas?
    Toyota Fortuner 3.0 D4D 2X4
    Colt 2.8 TDI 4X4 - It's not fast, it's not furious, but it's FUN!....being missed deeply!!

    FEAR is Temporary.... REGRET is Forever....
    Don't learn SAFETY by ACCIDENT!!
    Ps. I still pay in MUD PUDDLES

  10. #10
    Join Date
    Jan 2009
    Location
    Kempton Park
    Age
    49
    Posts
    202
    Thanked: 1

    Default

    The flashing green light in 2H means you are losing vacuum normaly it is the vacuum pipe the runs to the injector pump the is off or leaking just check the vacuum pipes against the fire wall
    Alfred
    Colt tdi 4x4
    Ford Ranger 2.2 xls sc 4x4

    The Roadside boy Sparkie

  11. #11
    Join Date
    Apr 2008
    Location
    BLOEMFONTEIN
    Age
    54
    Posts
    891
    Thanked: 176

    Default

    Check here, it explains the workings of Super Select.

    http://www.4x4wire.com/forums/showfl...gonew=1#UNREAD

    Also search the forum, 4ePikanini posted very usefull info here.

  12. #12
    Join Date
    Jul 2009
    Location
    Gauteng
    Age
    45
    Posts
    90
    Thanked: 1

    Default

    I've had the same problem - it's got something to do with a sensor somewhere on the transfer case.
    Hope this helps.

  13. #13
    Join Date
    Mar 2008
    Location
    Durbanville
    Age
    50
    Posts
    48
    Thanked: 0

    Default

    Hi All

    I have a similar problem of the intermittent flashing light when in normal drive. In addition my 4x4 wonít engage unless I pull one of the two vacuum lines connecting to the actuator on the front diff. Iíve noticed yesterday that if you engage 4x4 the light is constantly lit if the vehicle is not running. As soon as the engine is running, the light starts to flash indicating that the 4x4 system has not engaged. Iíve followed the pipes along the firewall and noted that one pipe connect to some type of small cylinder shaped connector in close proximity to the intercooler. There is another pipe that connects from this cylinder shaped thing to a bigger unit close to the throttle. Can it be that one of these two units is malfunctioning as I donít think it is an electrical problem in my uneducated opinion?

  14. #14
    Join Date
    Aug 2009
    Location
    Gezina
    Age
    53
    Posts
    185
    Thanked: 1

    Default

    hi coltspider.
    i had the exact same problem just a few weeks back.the vacuum system is only there to push the selector pin in when shifting into 4h on the fly.on mt 2002 colt 2.8 td there are no hubs that need to be locked by the vacuum, just the piston rod into the gearbox. this rod has a switch which tells the green light to come on when selecting 4h. when gearing back to 2h, the rod has a spring which pushes it back. as the pin goes back, the green light flashes and goes off when the switch is pushed in.
    my switch was faulty showing continuity when pushed in and when released. i left the switch in a cup of vinigar over night, as the acid cleaned the contacts,after testing the switch,it only showed continuity one way. problem solved

    paul moult
    2002 landrover discovery 2 td5
    burnco front bumper

  15. #15
    Join Date
    Apr 2010
    Location
    Pretoria
    Age
    36
    Posts
    62
    Thanked: 0

    Default

    I had the same problem problem, it turned out to be a loose vacuum pipe coming from the engine... I am almost sure it came of during a engine wash... Check all the pipes before replacing the switches.

  16. #16
    Join Date
    Nov 2007
    Location
    Cambridge, NZ
    Age
    51
    Posts
    1,595
    Thanked: 21

    Default

    I say you have the plugs the wrong way round.....8)

    Its not a super select system as on the Pajero, but it is based on it.


    2002 Colt, 2.8 tdi Rodeo, 4x4, ARB Bull Bar, Excalliber Running Boards, Monroe Gas Magnum Shocks, Cooper AT3's, Excel 53l long range tank, National Luna Dual Battery System, Campmaster 80l Fridge/Freezer Combo, FrontRunner Fridge slide and Bin Slide, Alpha Gte Canopy with FrontRunner Roof Rack and Homemade Awning...Pulling a Caravan sometimes

Similar Threads

  1. First Ever Kumho 4x4 FUN Day!
    By KumhoKL71 in forum Calender & Events
    Replies: 2
    Last Post: 2010/10/22, 09:08 AM
  2. bi-xenon lights and off road 4x4
    By ilikeit in forum General 4x4 Discussion
    Replies: 0
    Last Post: 2009/12/29, 11:47 PM
  3. D/Cab 4x4 Fog lights
    By AwakenZombie in forum Mitsubishi
    Replies: 10
    Last Post: 2007/06/03, 07:01 PM
  4. Another bash at The Rocky Mounatin 4x4 Trail
    By Big Hilux in forum Eastern Cape
    Replies: 5
    Last Post: 2007/02/20, 01:19 PM
  5. The Rocky Mountain 4x4 Trail
    By Big Hilux in forum Eastern Cape
    Replies: 0
    Last Post: 2007/01/21, 07:13 PM

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
  •