Results 1 to 6 of 6
  1. #1
    Join Date
    Oct 2009
    Location
    Hillcrest
    Age
    38
    Posts
    159
    Thanked: 0

    Default Jimny Rear Window Washer Leaking All Water

    Hi,

    I have a silly, yet annoying problem on my Jimny. It seems that when parked on a slight incline (as is done in my driveway at home), the water is leaking out the back winscreen washer hole, just behind the spare wheel. Problem is, it leaks until my washer bottle under the bonnet is empty. It never used to do this - seems like a new "feature" on my car.

    Anyone else got a similair problem, or know what causes it? I suppose I could alway reverse into my drive way each day to avoid the upward incline, but I'd prefer the problem to be fixed.

    Any suggestions would be appreciated.

  2. #2
    Join Date
    Jan 2008
    Location
    Durban
    Age
    40
    Posts
    1,280
    Thanked: 15

    Default

    Isn't the vehicle still under warranty?
    Mike

  3. #3
    Join Date
    Oct 2009
    Location
    Hillcrest
    Age
    38
    Posts
    159
    Thanked: 0

    Default

    Yes it is, and I'll ask them to have a look at my next service (4000km to go).

  4. #4
    Join Date
    Mar 2009
    Location
    Pinetown
    Age
    47
    Posts
    21
    Thanked: 0

    Default

    Mine has the same problem. Does not leak nearly as much as yours. Maybe 100-200ml every now and again.
    2009 Suzuki Jimny - Front Runner roofrack, Artav nudge and side bars, Towbar, 20% smash and grab, Clear side indicators, cracked headlight . 9.7L/100km.

  5. #5
    Join Date
    Oct 2009
    Location
    Umhlanga Rocks
    Age
    40
    Posts
    20
    Thanked: 0

    Default

    I have the same problem and will also try to get the agents to sort out next time.

    I guess one could try somehow mounting the washer bottle 300mm or so lower in the engine bay

  6. #6
    Join Date
    Oct 2009
    Location
    Hillcrest
    Age
    38
    Posts
    159
    Thanked: 0

    Default

    This seems like a common "feature". See: http://www.auszookers.com/index.php?...topic&p=109804

    If anyone manages a fix, please post it here :-)

Similar Threads

  1. An interesting TJ Jeep Article.
    By Big Hilux in forum Jeep
    Replies: 2
    Last Post: 2009/05/19, 10:31 PM
  2. Discovery I 2nd battery & window washer reservoir
    By Thys Willemse in forum Land Rover
    Replies: 0
    Last Post: 2007/07/19, 11:41 AM
  3. Window SOX
    By Ralph_Clark in forum General 4x4 Discussion
    Replies: 4
    Last Post: 2007/01/22, 08:08 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •