Page 1 of 2 1 2 LastLast
Results 1 to 20 of 29
  1. #1
    Join Date
    Sep 2009
    Location
    Pretoria
    Age
    56
    Posts
    49
    Thanked: 0

    Default Disco 3: Funny Alarm sound intermittantly

    I have a 2007 Discovery 3 TDV6 HSE. There is alarm (sound as if it just above the right rear wheel ) and the sound is similar to that of piezoelectric when locking and unlocking the car. The difference it is a continuous alarm like sound and it intermittently activates and needless to say, always in a situation where it is impossible to try and find the thing.
    Any guidance on what this is or how I could fault-find the culprit will be appreciated. (Wiring diagrams etc etc)

  2. #2
    Join Date
    Oct 2010
    Location
    Centurion
    Age
    37
    Posts
    5,721
    Thanked: 49

    Default

    Wow thats strange. I have never heard of that.

    So it is not the actual alarm that keeps going off?

    I cannot think of any motor or something by the right rear wheel.

    Discovery 3 V8 SE
    Self designed Rock and Tree Sliders.
    Next: Project Bashplate
    1981 Series 3 S R6 88" Allmost Perfectly Restored

  3. #3
    Join Date
    Sep 2009
    Location
    Pretoria
    Age
    56
    Posts
    49
    Thanked: 0

    Default

    It is some kind of alarm, but as I say very intermittent. Went off today again after about 2 weeks and kept on alarming for about 2 hours (nothing switches it off, not the remote, opening and closing the doors), unfortunately I was not here to try and find the problem. I suspect some wire fault somewhere but do not have any idea where to start. The only thing I know is that the sound comes from the right rear wheel side, but I am not even able to find the “Speaker”. Maybe I will remove the Plastic covers around the wheel arch this weekend end see if I am able to find a starting point to work from

  4. #4
    Join Date
    Jul 2008
    Location
    Pretoria
    Age
    60
    Posts
    44
    Thanked: 0

    Default

    I had the same problem. It is the sattelite tracking device's alarm. I phoned them (Netsar) and they came out and replaced a device behind the right rear seat. The guy said the battery (of the tracking device) was flat.

  5. #5
    Join Date
    Oct 2010
    Location
    Centurion
    Age
    37
    Posts
    5,721
    Thanked: 49

    Default

    Quote Originally Posted by greyneke View Post
    I have a 2007 Discovery 3 TDV6 HSE. There is alarm (sound as if it just above the right rear wheel ) and the sound is similar to that of piezoelectric when locking and unlocking the car. The difference it is a continuous alarm like sound and it intermittently activates and needless to say, always in a situation where it is impossible to try and find the thing.
    Any guidance on what this is or how I could fault-find the culprit will be appreciated. (Wiring diagrams etc etc)
    If it is the tracking device and you are not using it any more dont have netstar remove it and pay R350 for nothing. Remove it yourself. PM me I know where the unit is located.

    Discovery 3 V8 SE
    Self designed Rock and Tree Sliders.
    Next: Project Bashplate
    1981 Series 3 S R6 88" Allmost Perfectly Restored

  6. #6
    Join Date
    Sep 2006
    Location
    PTA
    Age
    46
    Posts
    1,193
    Thanked: 11

    Default

    Quote Originally Posted by lrbotha View Post
    I had the same problem. It is the sattelite tracking device's alarm. I phoned them (Netsar) and they came out and replaced a device behind the right rear seat. The guy said the battery (of the tracking device) was flat.
    100% correct, all D3 came standerd with Netstar fitted.....
    D4 V8
    Live life on the edge... you get a better view !
    Disco 3 Video
    http://www.youtube.com/watch?v=STt7DmJeeVc

  7. #7
    Join Date
    Jul 2007
    Location
    Durbanville
    Age
    59
    Posts
    625
    Thanked: 21

    Default

    Quote Originally Posted by TiaanS View Post
    100% correct, all D3 came standerd with Netstar fitted.....
    That is the fist time I heard of this - are you 100% sure?
    Andre du Toit

    Discovery 4 V8

    Jurgens Xplorer

  8. #8
    Join Date
    Sep 2006
    Location
    PTA
    Age
    46
    Posts
    1,193
    Thanked: 11

    Default

    Yip, had a problem with something draining the battery 2 weeks ago. LR just removed the fuse feeding the factory fitted Netstar unit and all OK
    D4 V8
    Live life on the edge... you get a better view !
    Disco 3 Video
    http://www.youtube.com/watch?v=STt7DmJeeVc

  9. #9
    Join Date
    Jul 2009
    Location
    Pretoria
    Age
    40
    Posts
    3,647
    Thanked: 188

    Default

    And yes all Disco 3 have Netstar fitted
    My wife is simple, in a complicated way

  10. #10
    Join Date
    Jul 2007
    Location
    Durbanville
    Age
    59
    Posts
    625
    Thanked: 21

    Default

    Just shows you again - you learn something new every day!

    Thanks
    Andre du Toit

    Discovery 4 V8

    Jurgens Xplorer

  11. #11
    Join Date
    Sep 2009
    Location
    Pretoria
    Age
    56
    Posts
    49
    Thanked: 0

    Default

    Thanks, Appreciate your input and help. Will try and hope this is the problem

  12. #12
    Join Date
    Sep 2009
    Location
    Pretoria
    Age
    56
    Posts
    49
    Thanked: 0

    Default

    Thanks to the help from the people on the forum, Removed the Tracking device and the battery, see photos, but the Alarm is still sounding. Then I removed the covers around the right back wheel and found the culprit. It is situated just above the 2nd tank. Now I have to trace the wires to see where it is connected to. I could cut the wires quit it up but do not want to do this as I believe the reason setting it off is still there.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	521.JPG 
Views:	836 
Size:	151.6 KB 
ID:	162991   Click image for larger version. 

Name:	529.JPG 
Views:	802 
Size:	108.8 KB 
ID:	162992   Click image for larger version. 

Name:	Foto 1.jpg 
Views:	653 
Size:	116.0 KB 
ID:	162993  

  13. #13
    Join Date
    Jan 2012
    Location
    Amanzimtoti
    Age
    69
    Posts
    453
    Thanked: 201

    Default

    Interested in finding out where the tracking system is so I can remove it or which fuse to pull to disconnect.

    On my previous Disco ( 2 ) when the disused tracker's battery packed up it pulled close to 2 amps from the main battery and drained it in no time. Don't want the same hassle with my D3 !

  14. #14
    Join Date
    Jan 2011
    Location
    barberton
    Age
    44
    Posts
    80
    Thanked: 0

    Default

    i know this is an old thread, but does anyone know which fuse feeds the tracker. instead of disconnecting the tracker, i could just save time and effort

  15. #15
    Join Date
    Oct 2006
    Location
    Durbanville
    Age
    56
    Posts
    180
    Thanked: 0

    Default

    I had the same alarm going off. Is it the tracker?
    00 Colt Rodeo 3000 auto - sold
    04 Disco 2 TD5 GS - sold
    07 Disco 3 TDV6 SE crank snaped scraped!!
    02 Jeep cherokee 3.7 LTD sold
    01 Jeep Grand Cherokee 4.7 LTD sold
    06 Jeep Grand Cherokee 4.7 Laredo sold
    17 Ford Ranger DC 2.2 manual 4x4
    00 Jeep Wrangler 4.0l sport manual

  16. #16
    Join Date
    Jun 2013
    Location
    KZN
    Age
    42
    Posts
    37
    Thanked: 1

    Default

    Man I hate you guys I read this thread last week and guess what happened this morning? Thats right, 6am leaving for work though the complex with this random alarm blaring. It only stopped after 10 minutes or so of driving, I'm guessing once the battery voltage rose a bit.Can someone please pm me the details on removing this un-used netstar unit, I'[m dreading it going off at work an annoying everyone in the nearby offices.
    Last edited by GuySA; 2014/04/29 at 08:53 AM.

  17. #17
    Join Date
    Apr 2009
    Location
    Durbanville
    Age
    46
    Posts
    793
    Thanked: 33

    Default

    Quote Originally Posted by GuySA View Post
    Man I hate you guys I read this thread last week and guess what happened this morning? Thats right, 6am leaving for work though the complex with this random alarm blaring. It only stopped after 10 minutes or so of driving, I'm guessing once the battery voltage rose a bit.Can someone please pm me the details on removing this un-used netstar unit, I'[m dreading it going off at work an annoying everyone in the nearby offices.
    Mine started going off yesterday . Alarm would sound every few minutes for a few minutes . Got the details for removing it and am going to give it a bash this afternoon

  18. #18
    Join Date
    Apr 2009
    Location
    Durbanville
    Age
    46
    Posts
    793
    Thanked: 33

    Default

    Looked in the recommended spots but nada . Any tips ?

  19. #19
    Join Date
    Oct 2012
    Location
    howick
    Age
    44
    Posts
    9
    Thanked: 0

    Default

    Please can someone pm the location.

    Got a range rover sport but I am sure that the location must be the same as a disco 3?

  20. #20
    Join Date
    Nov 2009
    Location
    Ballito
    Age
    50
    Posts
    1,010
    Thanked: 16

    Default

    Quote Originally Posted by twister View Post
    Please can someone pm the location.

    Got a range rover sport but I am sure that the location must be the same as a disco 3?

    pm sent
    2007 Mitsibushi Triton 2.5 Did 4x4 D/cab (Sold)

Page 1 of 2 1 2 LastLast

Similar Threads

  1. Disco II noise and transfer box
    By janfloris in forum Land Rover
    Replies: 16
    Last Post: 2010/08/31, 07:08 AM
  2. Jaloers op nuwe Disco 4
    By Disco3 in forum Land Rover
    Replies: 6
    Last Post: 2010/06/11, 11:22 AM
  3. Disco 2 Alarm system acting up
    By Boggom in forum Land Rover
    Replies: 5
    Last Post: 2009/07/24, 09:08 PM
  4. Disco alarm not stopping after new battery
    By Amalandy in forum Land Rover
    Replies: 2
    Last Post: 2009/07/04, 09:08 PM
  5. Disconnecting Disco I alarm
    By wulfe in forum Land Rover
    Replies: 4
    Last Post: 2008/11/04, 10:04 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •