Results 1 to 2 of 2
  1. #1
    Join Date
    Sep 2008
    Location
    Port Alfred
    Age
    68
    Posts
    284
    Thanked: 34

    Default Weird electrical problem with Triton 2.5

    Hi all - below is a problem experienced by my brother. He has a 2013 2.5 diesel Triton 4x4 d/c (manual).

    When switching off the Triton and removing the key, the bright headlights come on and a buzzing sound emits from under the bonnet. This goes on for about 6-8 seconds and then the lights go off. This happens even though the lights are turned off and no key in the ignition. NB: The lights are turned OFF when stopping the vehicle.
    When putting put the key back into the slot, as soon as it slides in the bright headlights come on.
    If you activate the central locking then the headlights go off.
    Disconnected and reconnected the battery but still same problem!

    Anyone experienced something like this before?
    Any ideas greatly appreciated!
    Triton 3.2 A/T D/Cab 4x4 (EGR blanked, Remapped, 63mm zorst)
    BL Vlooi 295
    Platkar - Rav4
    Previously: Isuzu "LUV", Disco D1 TDi, KZ-TE
    -------------------------------------------------------------------
    A bad day in the bush is better than a good day at the office

  2. #2
    Join Date
    Dec 2015
    Location
    North West Lichtenburg
    Age
    29
    Posts
    723
    Thanked: 60

    Default Re: Weird electrical problem with Triton 2.5

    Quote Originally Posted by dust-devil View Post
    Hi all - below is a problem experienced by my brother. He has a 2013 2.5 diesel Triton 4x4 d/c (manual).

    When switching off the Triton and removing the key, the bright headlights come on and a buzzing sound emits from under the bonnet. This goes on for about 6-8 seconds and then the lights go off. This happens even though the lights are turned off and no key in the ignition. NB: The lights are turned OFF when stopping the vehicle.
    When putting put the key back into the slot, as soon as it slides in the bright headlights come on.
    If you activate the central locking then the headlights go off.
    Disconnected and reconnected the battery but still same problem!

    Anyone experienced something like this before?
    Any ideas greatly appreciated!
    That is a strange one could it be a follow me home system perhaps that switches on the lights for you to get to the door then when you lock it with the remote it switches off I have seen something like that on some cars and my one friends Ranger does something similar

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •