GV in Limp Mode





Results 1 to 14 of 14

Thread: GV in Limp Mode

  1. #1
    Join Date
    Sep 2006
    Location
    Swellendam
    Age
    57
    Posts
    352
    Thanked: 4

    Default GV no power

    Hi all, I have enjoyed my 2010 2.4 Auto Grand Vitara for a good number of years and never had any issues.

    Saturday the car suddenly lost power / went into limp mode and shortly after that the yellow engine light on the dash came on.

    It rode, but slow, only managed 40kmh uphill and if you push the throttle the revs climbed almost like a clutch slipping. It felt like it was being throttled. Gearing down the engine revved higher then bogged down.

    I limped home and this morning took the car to the mech and they read code P0012 "'A' camshaft position timing over retarded". From what I read on Google its a generic code and can be a number of things.

    Background.
    Saturday I checked the car before the trip and found it needed oil. The oil was just on the dipstick so I filled it up with Total Quartz 9000 5W-40 which I had in the garage as I use it on my bikes - I am not sure what oil was in the car. I used a funnel so it was difficult to tell how much I put in, but it felt like a lot. The oil was in the middle of the dipstick when I was finished and is still there. There's nothing inside the filler cap that causes alarm - the mech checked this morning.

    I also topped up the radiator reservoir as it seemed a bit low (once again not alarmingly). This morning it looked like some fluid was gone so we topped it up and I will keep an eye on it.

    While riding, the car lost power and struggled with hills. It felt rough and used a lot of petrol. I also think I heard noises under the car like an exhaust rattling (knocking) somewhere but not sure if this is important.

    The situation now is the car is with me and the mech wants me to take it in for troubleshooting. I trust him completely but realize a lot of time can be wasted looking for faults and money is tight right now, so first wants to explore other avenues like the combined wisdom of this forum which I have been a member of for donkeys years.
    Last edited by Ratsalad; 2020/09/08 at 07:30 AM.

  2. #2
    Join Date
    Mar 2008
    Location
    De Wildt
    Age
    58
    Posts
    39,352
    Thanked: 15803

    Default Re: GV in Limp Mode

    " It felt rough and used a lot of petrol. I also think I heard noises under the car like an exhaust rattling (knocking)"

    Could be a broken cam or slipped cam chain (or slipped cam belt).

    Don't drive it like that.
    Jakes Louw
    2012 Jeep Sahara Unlimited 3.6 V6
    Percivamus

  3. #3
    Join Date
    Sep 2006
    Location
    Swellendam
    Age
    57
    Posts
    352
    Thanked: 4

    Default Re: GV no power

    The mech said it might be a stretched cam chain but also said the 2.4 is not known for that.
    The car has done 130 000 km's.
    Last edited by Ratsalad; 2020/09/08 at 12:02 PM.

  4. #4
    Join Date
    Sep 2006
    Location
    Swellendam
    Age
    57
    Posts
    352
    Thanked: 4

    Default Re: GV no power

    Update
    The mech told me to come fetch the car. They diagnosed a faulty torque convertor and said the car must go to a gearbox specialist in Cape Town as they cant do it.

    What would a job like this cost? I am in the dark here, any help or suggestions will be appreciated.
    Last edited by Ratsalad; 2020/09/08 at 12:03 PM.

  5. The Following User Says Thank You to Ratsalad For This Useful Post:


  6. #5
    Join Date
    Jun 2012
    Location
    Randburg
    Age
    34
    Posts
    158
    Thanked: 3

    Default Re: GV in Limp Mode

    Wow that sounds quite hectic... mine is a manual and the only time it went into Limp Mode was when it needed a new battery... in The Kruger Park... of course.

    Have you tried any of the Australian Suzuki Forums, or UK forums, where the car is quite popular and they have some real techies which talk about them?

    Also, perhaps chat to Suzuki Bramley... East Rand of Joburg... they excellent!

    Maybe even Wizerd, Suzuki parts expert.

    Sorry cant help more but maybe those leads can!

    Ps. it should be able to go way beyond 130000km but these funny things unfortunately happen from time to time.

    Byron
    Byron

    2012 GV 2.4M
    Lift
    Bashplates
    Goodyear Wrangler AT/SA 235/65/17

  7. #6
    Join Date
    Apr 2013
    Location
    Cape Town
    Age
    53
    Posts
    1,864
    Thanked: 249

    Default Re: GV in Limp Mode

    See this thread ... with this free app, and a small investment in a decent OBD device, you should be able to see exactly what is going on with your GV before you make any other decisions.

    https://www.4x4community.co.za/forum...41#post4319841

    Good luck!

    Suzi Blue , 2008 Nocturne Blue Suzuki Grand Vitara 3.2 V6

    Dobinson's 40mm suspension, Wizerd rock sliders, radiator, sump and diff plates
    Frontrunner RoofRack, NL 2nd Battery Box, Llumar sun protection
    16" Hyundai Tucson rims, 235/70R16 General Grabber AT3 tyres

  8. The Following User Says Thank You to daveysmith For This Useful Post:


  9. #7
    Join Date
    Sep 2006
    Location
    Swellendam
    Age
    57
    Posts
    352
    Thanked: 4

    Default Re: GV in Limp Mode

    Thank you ! I have almost given up on this thread.
    The car is parked for the time being I even put some Rattex in the engine bay!
    Ordering the scanner from Takealot now.

  10. #8
    Join Date
    Sep 2006
    Location
    Swellendam
    Age
    57
    Posts
    352
    Thanked: 4

    Default Re: GV in Limp Mode

    The Vgate was delivered today. I had it in the works car and cant wait to plug in the GV this weekend and hopefully get some more information.

  11. #9
    Join Date
    Jul 2008
    Location
    Constantia Kloof
    Age
    38
    Posts
    2,146
    Thanked: 1294

    Default Re: GV no power

    Quote Originally Posted by Ratsalad View Post
    Update
    The mech told me to come fetch the car. They diagnosed a faulty torque convertor and said the car must go to a gearbox specialist in Cape Town as they cant do it.

    What would a job like this cost? I am in the dark here, any help or suggestions will be appreciated.
    Silly question: Did Suzuki ever replace the gearbox oil as part of normal servicing or do they also call it a "filled for life" unit?
    Brandt Theunissen
    2019 Mahindra S6 Pik Up S/C 4x4
    2007 Mercedes Benz ML500 5.5
    1968 VW Beetle 2276

  12. #10
    Join Date
    Apr 2013
    Location
    Cape Town
    Age
    53
    Posts
    1,864
    Thanked: 249

    Default Re: GV in Limp Mode

    Quote Originally Posted by Ratsalad View Post
    The Vgate was delivered today. I had it in the works car and cant wait to plug in the GV this weekend and hopefully get some more information.
    I think you will be impressed how much info you get out of SZ viewer... hope it helps

    Suzi Blue , 2008 Nocturne Blue Suzuki Grand Vitara 3.2 V6

    Dobinson's 40mm suspension, Wizerd rock sliders, radiator, sump and diff plates
    Frontrunner RoofRack, NL 2nd Battery Box, Llumar sun protection
    16" Hyundai Tucson rims, 235/70R16 General Grabber AT3 tyres

  13. #11
    Join Date
    Sep 2006
    Location
    Swellendam
    Age
    57
    Posts
    352
    Thanked: 4

    Default Re: GV in Limp Mode

    I am using my wifes phone for the Vgate as I have an iPhone.
    I tried a laptop but it wouldnt connect.
    I got some info on her phone so it is working.
    Obviously the engine needs to be on and it was but I suppose it should also be driven?
    Does the 3.2 diagnostics differ from the 2.4 as the pics you posted shows a lot more info than what I got.
    If I post screen shots here would someone be able to help as I dont really know what I am looking at.

    @Koebelwagen I honestly dont know. The car has full service history with agents. I am the third owner.
    Last edited by Ratsalad; 2020/10/03 at 10:07 AM.

  14. #12
    Join Date
    Apr 2013
    Location
    Cape Town
    Age
    53
    Posts
    1,864
    Thanked: 249

    Default Re: GV in Limp Mode

    Quote Originally Posted by Ratsalad View Post
    I am using my wifes phone for the Vgate as I have an iPhone.
    I tried a laptop but it wouldnt connect.
    I got some info on her phone so it is working.
    Obviously the engine needs to be on and it was but I suppose it should also be driven?
    Does the 3.2 diagnostics differ from the 2.4 as the pics you posted shows a lot more info than what I got.
    If I post screen shots here would someone be able to help as I dont really know what I am looking at.

    @Koebelwagen I honestly dont know. The car has full service history with agents. I am the third owner.
    post screenshots - you should get more info as the sz viewer does not show engine info for the 3.2 as the 3.2 uses a modified GM protocol.

    You can also check out his web site ... http://malykh.com/soft/sz-viewer/
    Last edited by daveysmith; 2020/10/03 at 11:05 AM.

    Suzi Blue , 2008 Nocturne Blue Suzuki Grand Vitara 3.2 V6

    Dobinson's 40mm suspension, Wizerd rock sliders, radiator, sump and diff plates
    Frontrunner RoofRack, NL 2nd Battery Box, Llumar sun protection
    16" Hyundai Tucson rims, 235/70R16 General Grabber AT3 tyres

  15. The Following User Says Thank You to daveysmith For This Useful Post:


  16. #13
    Join Date
    Sep 2006
    Location
    Swellendam
    Age
    57
    Posts
    352
    Thanked: 4

    Default Re: GV in Limp Mode

    Will do so.
    Appreciate the help.

  17. #14
    Join Date
    Apr 2014
    Location
    Pretoria
    Age
    41
    Posts
    357
    Thanked: 17

    Default Re: GV in Limp Mode

    You said you checked the engine oil, did you also check the gearbox oil level? Had an old Rover SD when I was younger and had the same symptoms of revving but no speed/power. Good luck and hope you get the GV back onto the road with minimal expense.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •