SnapBridge - Nikon D500





Results 1 to 15 of 15
  1. #1
    Join Date
    Sep 2006
    Location
    Durban
    Age
    55
    Posts
    833
    Thanked: 227

    Default SnapBridge - Nikon D500

    Hi guys - my Nikon D500 initially did not have issues transferring photos from the camera to phone via the SnapBridge app, but it has now not done it for a while. I have Googled all the possible remedies, have deleted and re-install it etc, but it still does not work.

    It goes through all the motions but just does not transfer.

    Is there a fail-safe cure for the connection issues anyone know of?

    Thanks.
    2009 VW Touareg 3l V6 TDi
    2006 Isuzu DMax 300Tdi DC 4x4 (sold)

  2. #2
    Join Date
    Oct 2011
    Location
    Kempton Park
    Age
    46
    Posts
    3,320
    Thanked: 1024

    Default Re: SnapBridge - Nikon D500

    Personally I have never tried it, but I am just wondering: when last did you upgrade the firmware of your camera?

    I suspect Snapbridge, like most phone apps probably auto-updates, but the camera doesn't.
    1996 Patrol 4.2SGL with lots of stuff to make it heavier and thus increase traction?

  3. The Following User Says Thank You to Peter Connan For This Useful Post:


  4. #3
    Join Date
    Sep 2006
    Location
    Durban
    Age
    55
    Posts
    833
    Thanked: 227

    Default Re: SnapBridge - Nikon D500

    Hi Peter, never, how do I do that?
    2009 VW Touareg 3l V6 TDi
    2006 Isuzu DMax 300Tdi DC 4x4 (sold)

  5. #4
    Join Date
    Sep 2006
    Location
    Durban
    Age
    55
    Posts
    833
    Thanked: 227

    Default Re: SnapBridge - Nikon D500

    Don't stress, found this of Steve Perry on youtube, am sure it will have everything in it:

    https://www.youtube.com/watch?v=KEWQ4GCbWuI

    You have taught another thing today, thank you Peter Connan!
    2009 VW Touareg 3l V6 TDi
    2006 Isuzu DMax 300Tdi DC 4x4 (sold)

  6. The Following 2 Users Say Thank You to walkabout For This Useful Post:


  7. #5
    Join Date
    Oct 2011
    Location
    Kempton Park
    Age
    46
    Posts
    3,320
    Thanked: 1024

    Default Re: SnapBridge - Nikon D500

    Just hope it solves the problem!
    1996 Patrol 4.2SGL with lots of stuff to make it heavier and thus increase traction?

  8. The Following 3 Users Say Thank You to Peter Connan For This Useful Post:


  9. #6
    Join Date
    Feb 2016
    Location
    Port Elizabeth
    Age
    35
    Posts
    810
    Thanked: 941

    Default SnapBridge - Nikon D500

    At which exact step does it stop when you attempt to re-do the connection between camera and cellphone? Which cellphone do you have?

    A while ago I had the same issue. Also did a firmware update but to no avail. I had to disconnect/Ďforgetí all connections on the camera as well. Then reconnect as if itís the first time setting it up. Have you tried that?
    Last edited by MrTolbos; 2020/07/01 at 02:04 AM.

  10. The Following User Says Thank You to MrTolbos For This Useful Post:


  11. #7
    Join Date
    Sep 2006
    Location
    Durban
    Age
    55
    Posts
    833
    Thanked: 227

    Default Re: SnapBridge - Nikon D500

    HI MrTolbos, will check where exactly, it's been a while but like all things started to bother me as I might take some pics this weekend!

    I still have a Samsung S8, but have not done the procedure you described. Will do the firmware upgrade and take it from there and report back.
    2009 VW Touareg 3l V6 TDi
    2006 Isuzu DMax 300Tdi DC 4x4 (sold)

  12. #8
    Join Date
    Feb 2016
    Location
    Port Elizabeth
    Age
    35
    Posts
    810
    Thanked: 941

    Default Re: SnapBridge - Nikon D500

    Quote Originally Posted by walkabout View Post
    HI MrTolbos, will check where exactly, it's been a while but like all things started to bother me as I might take some pics this weekend!

    I still have a Samsung S8, but have not done the procedure you described. Will do the firmware upgrade and take it from there and report back.
    I had a quick look again, and Iím pretty sure it was the Bluetooth connection that I had to delete on the camera:






  13. The Following User Says Thank You to MrTolbos For This Useful Post:


  14. #9
    Join Date
    Sep 2006
    Location
    Durban
    Age
    55
    Posts
    833
    Thanked: 227

    Default Re: SnapBridge - Nikon D500

    Thanks, I have done it on the camera, thought you were talking about on the phone.

    Anyway, will do it today and report back later.
    2009 VW Touareg 3l V6 TDi
    2006 Isuzu DMax 300Tdi DC 4x4 (sold)

  15. #10
    Join Date
    Sep 2006
    Location
    Durban
    Age
    55
    Posts
    833
    Thanked: 227

    Default Re: SnapBridge - Nikon D500

    Ok have updated the firmware and it is definitely closer to happiness...it at least seems to connect phone & camera, it is just the last step where one is supposed to see the camera pictures on the phone where things are just blank (black screen). Yes there are pictures taken. Will try again tomorrow.
    2009 VW Touareg 3l V6 TDi
    2006 Isuzu DMax 300Tdi DC 4x4 (sold)

  16. The Following User Says Thank You to walkabout For This Useful Post:


  17. #11
    Join Date
    Sep 2006
    Location
    Durban
    Age
    55
    Posts
    833
    Thanked: 227

    Default Re: SnapBridge - Nikon D500

    Quote Originally Posted by MrTolbos View Post
    At which exact step does it stop when you attempt to re-do the connection between camera and cellphone? Which cellphone do you have?

    A while ago I had the same issue. Also did a firmware update but to no avail. I had to disconnect/Ďforgetí all connections on the camera as well. Then reconnect as if itís the first time setting it up. Have you tried that?
    I have now deleted the phone off the camera and vica versa. The phone does not seem to pick up the camera. If I scan for available devices it comes back with "no devices found".

    After a few tries it shows the camera but now says;"Couldn't pair. Check settings for this device and try again".

    Bluetooth is on on the camera but the "paired devices" option is now dull, so can't get there.

    Rather frustrating.
    2009 VW Touareg 3l V6 TDi
    2006 Isuzu DMax 300Tdi DC 4x4 (sold)

  18. #12
    Join Date
    Aug 2017
    Location
    Durban or Centurion
    Posts
    1,340
    Thanked: 1268

    Default Re: SnapBridge - Nikon D500

    I donít know if you have tried this, but perhaps it could help:

    https://www.nikonimgsupport.com/eu/B...ameOrigin=null

  19. #13
    Join Date
    Sep 2006
    Location
    Durban
    Age
    55
    Posts
    833
    Thanked: 227

    Default Re: SnapBridge - Nikon D500

    Will have a look thanks SAND.
    2009 VW Touareg 3l V6 TDi
    2006 Isuzu DMax 300Tdi DC 4x4 (sold)

  20. #14
    Join Date
    Sep 2006
    Location
    Durban
    Age
    55
    Posts
    833
    Thanked: 227

    Default Re: SnapBridge - Nikon D500

    Ok, somehow got everything connected again, in the process also updated the snapbridge app so that possible issue is now also eliminated. But I'm back at #10...so it does everything but showing me the photos. Will fight again tomorrow, rather frustrated now. Thanks for everyone's assistance.
    2009 VW Touareg 3l V6 TDi
    2006 Isuzu DMax 300Tdi DC 4x4 (sold)

  21. #15
    Join Date
    Aug 2017
    Location
    Durban or Centurion
    Posts
    1,340
    Thanked: 1268

    Default Re: SnapBridge - Nikon D500

    Shot in the dark here...

    Do you shoot RAW, or RAW+JPG? Perhaps try JPG or combination, and see if the images show.

  22. The Following User Says Thank You to SAND For This Useful Post:


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •