Another Terracan wont start





Results 1 to 10 of 10
  1. #1
    Join Date
    Jul 2018
    Location
    AK
    Posts
    10
    Thanked: 0

    Default Another Terracan wont start

    Hello,
    My Terracan 2.9 will only start with a shot of ether,

    have changed over from another going one

    Crank sensor
    cam sensor
    IVM (Inlet metering Valve)
    Knock sensor
    ECU and Key imo chip

    timming belt was one tooth advanced but has made no difference
    there is fuel pressure at the outlet of the pump when cranking ......with nut cracked alittle same as going one but not 1600bar its a fast dribble

    I did remove No. 1 injector and hooked it up to watch fuel pulse while cranking but it does not squirt until it starts which is the same as my going one ....so no difference there

    Strange thing.......It did start once with the front two injector pulse wires off ( so it started on only back two cylinders without ether) and idle but never again.

    only thing I havnt tried is Rail Pressure Sensor as looks like I need to remove inlet to take it off.........

    does anyone have any tricks I could try

    Cheers
    Buzz

  2. #2
    Join Date
    Jul 2016
    Location
    Midrand
    Age
    48
    Posts
    1,099
    Thanked: 494

    Default Re: Another Terracan wont start

    Once it starts with ether does it run normally? If so then you have an injector problem

  3. #3
    Join Date
    Jul 2018
    Location
    AK
    Posts
    10
    Thanked: 0

    Default Re: Another Terracan wont start

    Hi Mike, apart from seeming a little more gutless than my other truck yes it drives normal.

    another very strange thing.....the exhaust smell when it is running is a very sweet smell
    compared to my going one that is stinky as hell, same diesel etc

    Buzz

  4. #4
    Join Date
    Mar 2008
    Location
    De Wildt
    Age
    57
    Posts
    37,060
    Thanked: 13083

    Default Re: Another Terracan wont start

    Fuel pump, so I'd say a rail pressure check would be in order.
    2012 Jeep Sahara Unlimited 3.6 V6
    Percivamus

  5. #5
    Join Date
    Jul 2018
    Location
    AK
    Posts
    10
    Thanked: 0

    Default Re: Another Terracan wont start

    Jelo....how would I do that...id need a 25000 psi gauge to put on the end of a injector line?

  6. #6
    Join Date
    Jul 2016
    Location
    Midrand
    Age
    48
    Posts
    1,099
    Thanked: 494

    Default Re: Another Terracan wont start

    Quote Originally Posted by Buzzliteyear View Post
    Hi Mike, apart from seeming a little more gutless than my other truck yes it drives normal.

    another very strange thing.....the exhaust smell when it is running is a very sweet smell
    compared to my going one that is stinky as hell, same diesel etc

    Buzz
    Def sounds like an injector. Rail is not getting to the correct pressure with Normal cranking speed for the ecu to fire the injectors. If it was the pump it wouldn’t start at all.

  7. #7
    Join Date
    Jul 2016
    Location
    Midrand
    Age
    48
    Posts
    1,099
    Thanked: 494

    Default Re: Another Terracan wont start

    Quote Originally Posted by Buzzliteyear View Post
    Jelo....how would I do that...id need a 25000 psi gauge to put on the end of a injector line?
    You do it with a diagnostic machine. It will get pressure reading from the rail sensor

  8. #8
    Join Date
    Dec 2008
    Location
    cape town
    Age
    56
    Posts
    327
    Thanked: 160

    Default Re: Another Terracan wont start

    you could use a voltmeter on the wires to the sensor

    https://www.4x4community.co.za/forum...ensor-pin-outs

  9. #9
    Join Date
    Jul 2018
    Location
    AK
    Posts
    10
    Thanked: 0

    Default Re: Another Terracan wont start

    Of coarse.....

    voltage at rail pressure sensor listed below
    key on engine off 0.5 volts
    engine idle 1.2 v
    engine 2000rpm 2.2v


    both working and faulty trucks have the same voltage

    pulled apart injector looks clean,

    mike do you know if this part in the control valve is meant to have a hole through the middle ?

    Edit: I have tried three multi meters and all read about the same 0.1 - 0.2 ohms injector resistance
    fsm says should be below 1 ohm which they are.....
    Attached Images Attached Images  
    Last edited by Buzzliteyear; 2020/05/01 at 01:37 AM.

  10. #10
    Join Date
    Jul 2018
    Location
    AK
    Posts
    10
    Thanked: 0

    Default Re: Another Terracan wont start

    If im reading this correctly on closer inspection there is a blow out from the high pressure side
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	injector base A.jpg 
Views:	28 
Size:	258.0 KB 
ID:	569714   Click image for larger version. 

Name:	injector body B.jpg 
Views:	25 
Size:	311.6 KB 
ID:	569715  

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •