Fortuner D4D 3.0L uneven idle





Results 1 to 14 of 14
  1. #1
    Join Date
    Apr 2014
    Location
    centurion, pretoria
    Age
    44
    Posts
    40
    Thanked: 7

    Default D4D 3.0L uneven idle

    Hi there all

    Please comment on my observationsí
    I happily own a Fortuner 2011 d4d 3.0L (not the new shape)(and unfortunate not 4x4)
    I have noticed that when pulling the caravan for a while on a nice hot day that I get a shake in the vehicle when stopping at the robot just exiting the highway or stoping at the tollgate. It feels as the idle revs might just be too low and the whole vehicle shakes and vibrates. The idle is not erratic or uneven. Also the rev counter shows a steady 750-800 rpm. This situation is well noticeable when pulling the caravan and sometimes when not pulling and exiting the highway and stop at the lights or tollgate. The vehicle does not overheat and never had the needle shown above half temp gauge ever. I tow a med caravan at 110 km/h garmin speed and as per road conditions.
    I doubt that it is the injectors as I average 10 to 10.5 km/l and 7.5 to 8 km/l when towing (measured at the pump). I have not noticed any deviation in these figures during the 120 000km life span.
    So has anybody had similar experience or is this uncommon.
    Thanks for sharing and advising
    Ettienne

  2. #2
    Join Date
    Sep 2012
    Location
    Midrand
    Age
    39
    Posts
    663
    Thanked: 78

    Default

    Sticky ISCV perhaps?

    Does it happen only while stopped?
    Its not about how fast you are but about how quick you get there...


  3. #3
    Join Date
    Apr 2012
    Location
    Louis Trichardt, Limpopo
    Age
    51
    Posts
    1,217
    Thanked: 295

    Default

    Quote Originally Posted by Riempies PTA View Post
    Hi there all

    Please comment on my observationsí
    I happily own a Fortuner 2011 d4d 3.0L (not the new shape)(and unfortunate not 4x4)
    I have noticed that when pulling the caravan for a while on a nice hot day that I get a shake in the vehicle when stopping at the robot just exiting the highway or stoping at the tollgate. It feels as the idle revs might just be too low and the whole vehicle shakes and vibrates. The idle is not erratic or uneven. Also the rev counter shows a steady 750-800 rpm. This situation is well noticeable when pulling the caravan and sometimes when not pulling and exiting the highway and stop at the lights or tollgate. The vehicle does not overheat and never had the needle shown above half temp gauge ever. I tow a med caravan at 110 km/h garmin speed and as per road conditions.
    I doubt that it is the injectors as I average 10 to 10.5 km/l and 7.5 to 8 km/l when towing (measured at the pump). I have not noticed any deviation in these figures during the 120 000km life span.
    So has anybody had similar experience or is this uncommon.
    Thanks for sharing and advising
    Ettienne



    for what its worth, do you not think it might be the aircon pump stopping and starting which draws engine power and ultimately will have influence on the rev counter and idling speed.
    '13 Toyota Hilux 4x4 XCab

  4. #4
    Join Date
    Jun 2012
    Location
    Kempton Park
    Age
    44
    Posts
    1,208
    Thanked: 152

    Default

    Quote Originally Posted by Riempies PTA View Post
    the whole vehicle shakes and vibrates. The idle is not erratic or uneven. Also the rev counter shows a steady 750-800 rpm. This situation is well noticeable when pulling the caravan and sometimes when not pulling and exiting the highway and stop at the lights or tollgate

    Hi Ettienne,
    Manual or auto transmission?
    Only when its a hot day or when vehicle has worked a bit?

  5. #5
    Join Date
    Dec 2011
    Location
    East London
    Age
    35
    Posts
    17,047
    Thanked: 2372

  6. #6
    Join Date
    Apr 2014
    Location
    centurion, pretoria
    Age
    44
    Posts
    40
    Thanked: 7

    Default

    Sorry

    its a manual.

    and what is ISCV ?

    Ettienne

  7. #7
    Join Date
    Jun 2012
    Location
    Kempton Park
    Age
    44
    Posts
    1,208
    Thanked: 152

    Default

    SCV = suction control valve on the pump, but I doubt if that's the problem - you will have save mode issues.


    Manual box: are the gear shifts smooth?
    Last edited by Jack Russell; 2016/01/11 at 11:40 AM.

  8. #8
    Join Date
    Apr 2014
    Location
    centurion, pretoria
    Age
    44
    Posts
    40
    Thanked: 7

    Default

    Quote Originally Posted by Jack Russell View Post
    Hi Ettienne,
    Manual or auto transmission?
    Only when its a hot day or when vehicle has worked a bit?

    Manual Trans

    Sometimes if i drove hard on highway without the caravan and
    Usually when towing caravan

    More a shake than a vibrate

  9. #9
    Join Date
    Apr 2014
    Location
    centurion, pretoria
    Age
    44
    Posts
    40
    Thanked: 7

    Default

    Quote Originally Posted by Jack Russell View Post
    SCV = suction control valve on the pump, but I doubt if that's the problem - you will have save mode issues.


    Manual box: is the gear shifts smooth?

    Smooth shifting, no problems detected there

  10. #10
    Join Date
    Jun 2012
    Location
    Kempton Park
    Age
    44
    Posts
    1,208
    Thanked: 152

    Default

    See the fact that you have shakes and body vibration has to do with moving parts (i.e. engine or transmission)
    If the gear shifts were sticky then it could be clutch or master /slave cylinder issues - but you ruled this out.


    EGR valve sticky or blocked partially? Marius what do you think?

  11. #11
    Join Date
    Dec 2011
    Location
    East London
    Age
    35
    Posts
    17,047
    Thanked: 2372

  12. #12
    Join Date
    Sep 2012
    Location
    Midrand
    Age
    39
    Posts
    663
    Thanked: 78

    Default

    ISCV = Idle Speed Control Valve
    Its not about how fast you are but about how quick you get there...


  13. #13
    Join Date
    Jun 2012
    Location
    Kempton Park
    Age
    44
    Posts
    1,208
    Thanked: 152

    Default

    Quote Originally Posted by MariusFourie View Post
    I would think a sticky EGR valve or even a dirty MAF (if it has one)
    has one after air box

    Quote Originally Posted by Die$eL View Post
    ISCV = Idle Speed Control Valve
    cool thanks

  14. #14
    Join Date
    Feb 2020
    Location
    De Aar
    Posts
    1
    Thanked: 0

    Default Re: D4D 3.0L uneven idle

    Quote Originally Posted by Riempies PTA View Post
    Hi there all

    Please comment on my observations’
    I happily own a Fortuner 2011 d4d 3.0L (not the new shape)(and unfortunate not 4x4)
    I have noticed that when pulling the caravan for a while on a nice hot day that I get a shake in the vehicle when stopping at the robot just exiting the highway or stoping at the tollgate. It feels as the idle revs might just be too low and the whole vehicle shakes and vibrates. The idle is not erratic or uneven. Also the rev counter shows a steady 750-800 rpm. This situation is well noticeable when pulling the caravan and sometimes when not pulling and exiting the highway and stop at the lights or tollgate. The vehicle does not overheat and never had the needle shown above half temp gauge ever. I tow a med caravan at 110 km/h garmin speed and as per road conditions.
    I doubt that it is the injectors as I average 10 to 10.5 km/l and 7.5 to 8 km/l when towing (measured at the pump). I have not noticed any deviation in these figures during the 120 000km life span.
    So has anybody had similar experience or is this uncommon.
    Thanks for sharing and advising
    Ettienne


    More Riempies, ek sien dis n ou post maar ek sit nou met die selfde probleem op my 3.0 Fortuner. Op die hele internet is jou geval die enigste een wat ek kon kry met die selfde simptome. Die skud van die engine en voertuig kom en gaan van tyd tot tyd. Soms gaan daar dae verby wat hy dit glad nie doen nie. Het clutch kit, flywheel en injectors gedoen so 7000km terug en November het hy begin met die skud. Warm of koud. Ek sal 350km ry sonder n probleem, stop voertuig afskakel en 5min later as ek hom start dan begin hy dans. Soms meer as ander kere. Kon jy vastel wat die oorsak was? Sal teruvoer baie waardeer. Ian
    Last edited by IanNc; 2020/02/12 at 09:21 AM.

Similar Threads

  1. D-teq uneven idle and sometimes dies
    By Namakwalander in forum Isuzu
    Replies: 27
    Last Post: 2018/01/19, 01:38 PM
  2. Toyota Hilux Snorkel D4D 3.0L
    By rssfeed in forum For Sale, Swop & Give-Away
    Replies: 0
    Last Post: 2015/03/26, 10:20 AM
  3. Cherokee XJ 4.0 Misfire Gremlin .....
    By Johann van Rensburg in forum Jeep
    Replies: 109
    Last Post: 2015/03/11, 07:46 AM
  4. Replies: 17
    Last Post: 2008/04/08, 09:25 PM
  5. Replies: 3
    Last Post: 2008/02/17, 11:54 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •