Electrical issue





Results 1 to 6 of 6
  1. #1
    Join Date
    Oct 2017
    Location
    Paarl
    Posts
    64
    Thanked: 29

    Default Electrical issue

    Hi guys. I drive an Isuzu KB 250 single cab lwb, 2004 model.

    I had these lights come on intermittently about 2000km ago, always on now. Everything works except the fan. Replaced my alternator about 10 000km ago and my battery is new and fully charged.

    Please help!

    Thanks

    Ben
    Attached Images Attached Images  

  2. #2
    Join Date
    Jan 2012
    Location
    King Williams Town
    Age
    52
    Posts
    7,526
    Thanked: 1112

    Default Re: Electrical issue

    Remove radiator and remove and unbind wires that run under the radiator over the chassis. Clean each wire and then pull each wire through your finger tips, feeling for little bumps, also look for little black dots. Maybe testing each wire from one side of left fender to right fender using a multi meter may help. I found 6 wires having these black dots. When I cut them open I found the copper wire turned black meaning it had chafed through on the chassis. My aircon fan did not work. Replaced a few wires, reaped up and away I went. Good luck, my money is on the chafed wires under the radiator.
    Isuzu STD 2.5d 2x4 rear diffy lock
    2x spotlight,2x fog lights
    215/80/R15c tyres
    1 x great humourous driver
    GPS,Bluetooth
    Eagle eye dash cam --stolen ..bought another one
    snorkel soon
    Craig
    I DON'T LIVE IN AFRICA,AFRICA LIVES IN ME- Kyle my son

  3. The Following User Says Thank You to hunter26 For This Useful Post:


  4. #3
    Join Date
    Dec 2009
    Location
    Rayton
    Age
    52
    Posts
    62
    Thanked: 7

    Default Re: Electrical issue

    Think that light on the left, indicate that you need to clean the diesel filter water trap. - small tap under the diesel filter housing - open it and catch the water / diesel in a bottle to see if it is clean diesel.

  5. The Following User Says Thank You to Waccro For This Useful Post:


  6. #4
    Join Date
    Jan 2009
    Location
    Germiston
    Age
    38
    Posts
    3,785
    Thanked: 95

    Default Re: Electrical issue

    Alternator. Check that the belt is running tight also. Check all the plugs, make sure they all in properly on the alternator
    __________________
    '01 Isuzu Frontier LX 4x4 Diesel8) - For the brown Stuff
    '14 Renault Sandero 900cc Dynamique, small with a big heart

  7. The Following User Says Thank You to sweeper For This Useful Post:


  8. #5
    Join Date
    Oct 2017
    Location
    Paarl
    Posts
    64
    Thanked: 29

    Default Re: Electrical issue

    Ended up being a plug at the back of the alternator. Quick fix with a little bit of wiggling and pushing.

  9. #6
    Join Date
    Jan 2012
    Location
    King Williams Town
    Age
    52
    Posts
    7,526
    Thanked: 1112

    Default Re: Electrical issue

    Quote Originally Posted by Ben Coetzee View Post
    Ended up being a plug at the back of the alternator. Quick fix with a little bit of wiggling and pushing.
    Damit and we were all so close.

    Thanks for the feed back.
    Isuzu STD 2.5d 2x4 rear diffy lock
    2x spotlight,2x fog lights
    215/80/R15c tyres
    1 x great humourous driver
    GPS,Bluetooth
    Eagle eye dash cam --stolen ..bought another one
    snorkel soon
    Craig
    I DON'T LIVE IN AFRICA,AFRICA LIVES IN ME- Kyle my son

  10. The Following User Says Thank You to hunter26 For This Useful Post:


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •