National Luna Dual Refrigerator 12v issues





Results 1 to 8 of 8
  1. #1
    Join Date
    Nov 2011
    Location
    Vryburg
    Age
    41
    Posts
    20
    Thanked: 4

    Default National Luna Dual Refrigerator 12v issues

    Hi.
    I have a conqueror conquest trailer with a NL dual fridge/freezer. I hope there is someone who can give some advice on sorting the issue.

    When the fridge is connected to 230v. Everything works fine. When connected to 12v the NL starts then stops and the fault light blinks 2 times.

    Connecting the NL directly to the battery (took it out and put it next to the NL.. still same issue..
    Connecting it to a bigger battery (next to NL) Then we get no faults.. and NL is working perfectly from the bigger battery..
    install the bigger battery in the nose of the conquest.. connect to bigger battery... and it switches of again...
    connect wires directly to bigger battery (with other (+-3mm) in front without anything else connected.. an NL is not working...

    The only time the NL worked on 12v is when the bigger battery was less than 1meter from it and connected directly...

    Can it be the fan (fault ID Indicates 2 flashes = fan issues) The fan is working fine on 230v

    did anyone have the same problem?

    Advice would be great!

  2. #2
    Join Date
    Oct 2017
    Location
    Rustenburg
    Age
    50
    Posts
    2,013
    Thanked: 1296

    Default Re: National Luna Dual Refrigerator 12v issues

    Quote Originally Posted by AdventureGirl View Post
    Hi. I have a conqueror conquest trailer with a NL dual fridge/freezer. I hope there is someone who can give some advice on sorting the issue. When the fridge is connected to 230v. Everything works fine. When connected to 12v the NL starts then stops and the fault light blinks 2 times. Connecting the NL directly to the battery (took it out and put it next to the NL.. still same issue.. Connecting it to a bigger battery (next to NL) Then we get no faults.. and NL is working perfectly from the bigger battery.. install the bigger battery in the nose of the conquest.. connect to bigger battery... and it switches of again... connect wires directly to bigger battery (with other (+-3mm) in front without anything else connected.. an NL is not working... The only time the NL worked on 12v is when the bigger battery was less than 1meter from it and connected directly... Can it be the fan (fault ID Indicates 2 flashes = fan issues) The fan is working fine on 230vdid anyone have the same problem?Advice would be great!
    If there is a low voltage cutoff setting on the fridge, it might be set too high..
    _______________________________________Dum vivimus, vivamus!With a mild case of "Camping Personality Disorder" or CPD I drive a five cylinder bakkie and tow an army inspired van.

  3. #3
    Join Date
    Nov 2011
    Location
    Vryburg
    Age
    41
    Posts
    20
    Thanked: 4

    Default Re: National Luna Dual Refrigerator 12v issues

    Quote Originally Posted by Hedgehog View Post
    If there is a low voltage cutoff setting on the fridge, it might be set too high..
    Don't think there is... Click image for larger version. 

Name:	50B8FD32-EF41-43BC-8364-61450FD690E8.jpg 
Views:	242 
Size:	80.3 KB 
ID:	554845

  4. #4
    Join Date
    Jul 2011
    Location
    Roodepoort
    Age
    34
    Posts
    217
    Thanked: 19

    Default Re: National Luna Dual Refrigerator 12v issues

    Do you have the same problem when running it directly from a vehicle whilst the engine is running? (I.e. from the alternator?)
    Hilux 3.0 D4D 4x4; Stofpad Bashplate; LR tank; Racor

  5. #5
    Join Date
    Oct 2008
    Location
    Pretoria
    Age
    55
    Posts
    284
    Thanked: 9

    Default Re: National Luna Dual Refrigerator 12v issues

    Hi, that fridge do have low voltage settings, refer to the manual or contact National Luna in Edenvale. It's not that easy to go into the settings for obvious reasons.

  6. #6
    Join Date
    Feb 2011
    Location
    Vanderbijl Park
    Age
    47
    Posts
    188
    Thanked: 13

    Default Re: National Luna Dual Refrigerator 12v issues

    I don't know how old your Conquest is but I had the same issue and do understand that the newer models have been corrected. The electrical cable used is not thick enough and I had to replace to a thicker cable and then sorted out. National luna's manual requires 4mm˛ or grater and this is not what was in my Conquest. See attached extract from National Luna's manual.
    Attached Images Attached Images  

  7. #7
    Join Date
    Apr 2019
    Location
    Midrand
    Posts
    277
    Thanked: 305

    Default Re: National Luna Dual Refrigerator 12v issues

    Quote Originally Posted by Quintin2812 View Post
    I don't know how old your Conquest is but I had the same issue and do understand that the newer models have been corrected. The electrical cable used is not thick enough and I had to replace to a thicker cable and then sorted out. National luna's manual requires 4mm˛ or grater and this is not what was in my Conquest. See attached extract from National Luna's manual.

    agree. Conqueror used some woefully undersized wiring- that leads to voltage drop - and that fridge has adjustable low voltage cutout. The thin wiring is likely leading to low voltage cutout.

  8. #8
    Join Date
    Jun 2007
    Location
    centurion
    Posts
    136
    Thanked: 25

    Default Re: National Luna Dual Refrigerator 12v issues

    Quote Originally Posted by heyyahhey View Post
    agree. Conqueror used some woefully undersized wiring- that leads to voltage drop - and that fridge has adjustable low voltage cutout. The thin wiring is likely leading to low voltage cutout.
    Had the same on my Echo, so for a short term fix Ive set the cutout voltage on the NL to minimum to let the battery system controller manage the battery.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •