Discover Battery Issue





Results 1 to 10 of 10
  1. #1
    Join Date
    Jan 2019
    Location
    Despatch
    Posts
    32
    Thanked: 7

    Default Discover Battery Issue

    Morning all

    Just got back from our camping holiday, and had a really good break. We camped 2 days at a non power site and that is where our problem started with one of our batteries. We had our solar panels out to charge the battery and everything worked fine. Panels recharged battery to full capacity by 1pm and float charged till it was night time. At about 8pm the fridge basically cuts out due to low voltage from battery. Same happened on day 2. What can cause this battery to crash and lose voltage so quickly? I must also add, after big voltage drop, battery goes back to a 13 volt float and fridge starts again, just to cut out a few seconds later when voltage drops again. I bought the discover battery at a premium price as i was told these are very good batteries. They are basically twice the value of a normal deep cycle so not very happy at the moment.

    Discover Dry Traction Cell AGM 100ah (1.5 years old)
    CTEK D250SA Charger, DC to DC and Solar
    CTEK 220V 5A Charger permanently connected at home (Float Charging)
    National Luna 90LT Legacy Twin

    I have tested the same setup with a new deep cycle i bought when we arrived back, and 90lt Luna runs for 3 days on same temp setting before battery gets to dangerously low.
    2019 Isuzu 2.5 D-Teq Supercab
    2004 Ford 2.5 Ranger Supercab
    Jurgens XT-140 Trailer


  2. #2
    Join Date
    Feb 2017
    Location
    Santa Cruz, CA
    Posts
    293
    Thanked: 205

    Default Re: Discover Battery Issue

    Quote Originally Posted by Vlam86 View Post
    Morning all

    Just got back from our camping holiday, and had a really good break. We camped 2 days at a non power site and that is where our problem started with one of our batteries. We had our solar panels out to charge the battery and everything worked fine. Panels recharged battery to full capacity by 1pm and float charged till it was night time. At about 8pm the fridge basically cuts out due to low voltage from battery. Same happened on day 2. What can cause this battery to crash and lose voltage so quickly? I must also add, after big voltage drop, battery goes back to a 13 volt float and fridge starts again, just to cut out a few seconds later when voltage drops again. I bought the discover battery at a premium price as i was told these are very good batteries. They are basically twice the value of a normal deep cycle so not very happy at the moment.

    Discover Dry Traction Cell AGM 100ah (1.5 years old)
    CTEK D250SA Charger, DC to DC and Solar
    CTEK 220V 5A Charger permanently connected at home (Float Charging)
    National Luna 90LT Legacy Twin

    I have tested the same setup with a new deep cycle i bought when we arrived back, and 90lt Luna runs for 3 days on same temp setting before battery gets to dangerously low.
    I was quite interested in this same battery, too bad to hear that it gave you trouble. Did you ever get to the bottom of this mystery?

  3. #3
    Join Date
    Jan 2016
    Location
    Richardsbay
    Age
    42
    Posts
    176
    Thanked: 78

    Default Re: Discover Battery Issue

    They are still one of the best around, check it out something is wrong!

  4. The Following User Says Thank You to Frikstervx200 For This Useful Post:


  5. #4
    Join Date
    Oct 2019
    Location
    Pretoria
    Posts
    13
    Thanked: 1

    Default Re: Discover Battery Issue

    Same setup same problem and batt was replaced under warranty.

  6. #5
    Join Date
    Jan 2018
    Location
    Harare
    Posts
    146
    Thanked: 94

    Default Re: Discover Battery Issue

    Same problem. We live in our Bush Lapa permanently. We purchased 3 x Discover EV27A 100A/h Dry Cell Batteries in June last year. We use one in our Toyota Hilux running a 90l National Lunar (fitted with a Danfoss, not the legacy range) and it is charged via a WRND using either the car alternator or a 100w solar panel, when we are at a powered site we use 240v directly. There have been no hassles whatsoever, the battery is great.

    Bush Lapa fitted the other 2 batteries into our Baobab caravan, these run the same model National Luna as in my car plus lights, USBs etc. These two batteries are charged by either a 190w solar panel via a Victron MPPT100/15 controller when offgrid or via electricity via a Victron IP65 12v 15amp smart charger when at a powered site, the smart charger as advised by both Bush Lapa and Enertec is set on high (14.7v).

    After 5 months of use my National Luna started cutting out despite the battery showing as fully charged. This only happened when there was no 240v incoming. The reading on the Victron monitor would read over 13.0 and would quickly go down to less than 10.5 and the NL would cut out. The battery would immediately return to over 13.0, the NL would restart and the cycle would repeat itself within 60 seconds, this was ongoing so I disconnected the NL. I suspected the NL was faulty so I put my vehicle NL in the caravan and exactly the same thing happened.

    Using the Bush Lapa factory, Enertec tested both batteries and confirmed that the batteries were at fault and replaced the batteries under warranty. They said that they had never encountered this problem before but as per above folk clearly there is a problem. I don't understand as my battery in the car is giving no hassles and I'm afraid that I'll encounter the same problem again in a few months time. These batteries come at a significant premium and I can't afford to replace batteries after 12 months. Any advice would be appreciated
    Last edited by Tedx2; 2020/03/15 at 04:50 PM.
    John
    2014 Toyota Hilux 4x4 3.0 D4D
    Baobab BL1715
    Don't let your dreams remain dreams


  7. #6
    Join Date
    Apr 2008
    Location
    Waverley, Pretoria
    Age
    58
    Posts
    350
    Thanked: 70

    Default Re: Discover Battery Issue

    Following as I am about to purchase the same battery for my caravan

    '15 Prado 4.0 VX
    '13 Jurgens Xcell
    '18 Echo Chobe (sold)

  8. #7
    Join Date
    Jan 2015
    Location
    Cape Town
    Age
    43
    Posts
    5
    Thanked: 0

    Default Re: Discover Battery Issue

    Quote Originally Posted by Tedx2 View Post
    Same problem. We live in our Bush Lapa permanently. We purchased 3 x Discover EV27A 100A/h Dry Cell Batteries in June last year. We use one in our Toyota Hilux running a 90l National Lunar (fitted with a Danfoss, not the legacy range) and it is charged via a WRND using either the car alternator or a 100w solar panel, when we are at a powered site we use 240v directly. There have been no hassles whatsoever, the battery is great.

    Bush Lapa fitted the other 2 batteries into our Baobab caravan, these run the same model National Luna as in my car plus lights, USBs etc. These two batteries are charged by either a 190w solar panel via a Victron MPPT100/15 controller when offgrid or via electricity via a Victron IP65 12v 15amp smart charger when at a powered site, the smart charger as advised by both Bush Lapa and Enertec is set on high (14.7v).

    After 5 months of use my National Luna started cutting out despite the battery showing as fully charged. This only happened when there was no 240v incoming. The reading on the Victron monitor would read over 13.0 and would quickly go down to less than 11.5 and the NL would cut out. The battery would immediately return to over 13.0, the NL would restart and the cycle would repeat itself within 60 seconds, this was ongoing so I disconnected the NL. I suspected the NL was faulty so I put my vehicle NL in the caravan and exactly the same thing happened.

    Using the Bush Lapa factory, Enertec tested both batteries and confirmed that the batteries were at fault and replaced the batteries under warranty. They said that they had never encountered this problem before but as per above folk clearly there is a problem. I don't understand as my battery in the car is giving no hassles and I'm afraid that I'll encounter the same problem again in a few months time. These batteries come at a significant premium and I can't afford to replace batteries after 12 months. Any advice would be appreciated
    Out of interest, what cut out setting on the NL fridge is sellected?

  9. #8
    Join Date
    Jan 2019
    Location
    White River
    Posts
    67
    Thanked: 16

    Default Re: Discover Battery Issue

    Same problem with Mixtech batterys. Run 2 in parallel and one dies resulting in reduced installation capacity. This happened to me twice and I fortunatly piched up the second failure while it was under warranty.

  10. #9
    Join Date
    Jan 2018
    Location
    Harare
    Posts
    146
    Thanked: 94

    Default Re: Discover Battery Issue

    Quote Originally Posted by FistyCups View Post
    Out of interest, what cut out setting on the NL fridge is sellected?
    We have set at medium, which is 10.5v, sorry there was an error in my original post, it should have read less than 10.5 not less than 11.5, that was a typo error
    John
    2014 Toyota Hilux 4x4 3.0 D4D
    Baobab BL1715
    Don't let your dreams remain dreams


  11. #10
    Join Date
    Apr 2009
    Location
    East London
    Age
    66
    Posts
    1,000
    Thanked: 147

    Default Re: Discover Battery Issue

    will be watching the thread since i also have a discover dry cycle in my caravan ;

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •