Defender Td5 not starting





Results 1 to 18 of 18
  1. #1
    Join Date
    Sep 2018
    Location
    East London
    Posts
    84
    Thanked: 2

    Default Td5 not starting

    Hi all
    Took both landies to Smitskraal at Baviaans today. Stopped for half an hour but when leaving we found that no lights came on when turning the key. Checked all fuses and earthing without success. Tried jump starting also with no difference. Hooter works, brights and hazards work. No dim and no indicators.
    Eventually left the landy at Smitskraal picnic area and will go back tomorrow. It is a 3 hour drive one way.
    Could anyone help with a sequence of what to check and if neccessary is there a way I could bypass things just to get the landy back to St Francis. Thanks.

  2. #2
    Join Date
    Nov 2011
    Location
    Langebaanweg
    Age
    42
    Posts
    1,510
    Thanked: 918

    Default Re: Td5 not starting

    Ignition?
    '07 Land Rover Defender 110 TDI 300 Kalahari (Meisiekind˛)

    84' Land Rover Defender 110 V8 4-speed Hardtop (Meisiekind) Sold after 12 years of fun and hard work




    The only thing needed for evil to triumph is for a good man to do nothing.

  3. #3
    Join Date
    Sep 2018
    Location
    East London
    Posts
    84
    Thanked: 2

    Default Re: Td5 not starting

    Possibly. I will go back in the morning with a multimeter and slowly go through all the wiring connections, fuses and relays. Problem is if I cant find the fault there is no way I can get it back.

  4. #4
    Join Date
    Nov 2011
    Location
    Langebaanweg
    Age
    42
    Posts
    1,510
    Thanked: 918

    Default Re: Td5 not starting

    If it was worn out by age or heavy keys it will turn but nothing will happen.
    '07 Land Rover Defender 110 TDI 300 Kalahari (Meisiekind˛)

    84' Land Rover Defender 110 V8 4-speed Hardtop (Meisiekind) Sold after 12 years of fun and hard work




    The only thing needed for evil to triumph is for a good man to do nothing.

  5. #5
    Join Date
    Sep 2018
    Location
    East London
    Posts
    84
    Thanked: 2

    Default Re: Td5 not starting

    There are no lights coming on on the dash.

  6. #6
    Join Date
    Mar 2015
    Location
    New Germany
    Age
    49
    Posts
    1,141
    Thanked: 451

    Default Re: Td5 not starting

    Did you check fuses under drivers seat, also check ignition barrel at the end a wire could of come off one of the terminals,
    1995 300TDi Defender with VGT Turbo
    2002 Defender with LS1 MS3 ECU, 4L80e, LT230 1.222, Lockers and HD CW&P, 35" with 4" Lift

  7. #7
    Join Date
    Sep 2018
    Location
    East London
    Posts
    84
    Thanked: 2

    Default Re: Td5 not starting

    Thanks
    I will check tomorrow. Any other suggestions would be appreciated.

  8. #8
    Join Date
    Mar 2013
    Location
    Centurion
    Age
    27
    Posts
    939
    Thanked: 366

    Default Re: Td5 not starting

    Check relays under seat and all fuses very carefully. Take a few relays and fuses.

    Ive had battery terminals corrode slightly and had to take off terminals and sand lightly for a similar issue.
    Pieter Greyling
    ONE LIFE, LIVE IT!
    ORRA: Z85

    -Land Rover Defender 110 Td5
    -BMW G650 xChallenge

  9. #9
    Join Date
    Mar 2015
    Location
    New Germany
    Age
    49
    Posts
    1,141
    Thanked: 451

    Default Re: Td5 not starting

    one of the best things to get is a 12 Volt power prob it will tell you if have 12+ or - at the terminal and you can force activate either +or - to the circuit for testing, mine lives in the Landy helped out so many times
    Attached Images Attached Images  
    Last edited by clivemd; 2019/12/29 at 09:06 PM.
    1995 300TDi Defender with VGT Turbo
    2002 Defender with LS1 MS3 ECU, 4L80e, LT230 1.222, Lockers and HD CW&P, 35" with 4" Lift

  10. #10
    Join Date
    Oct 2015
    Location
    Pretoria
    Age
    38
    Posts
    448
    Thanked: 80

    Default Re: Td5 not starting

    Yes check the main relay under the seat. I had it once. Glowplug light dont come on and pump dont prime even.
    Other than that it sound electrical. Have you got a Hawkeye to scan with?
    Sterkte
    Last edited by Wildkyker; 2019/12/29 at 09:14 PM.
    ONE LIFE!

  11. #11
    Join Date
    Dec 2008
    Location
    cape town
    Age
    55
    Posts
    321
    Thanked: 154

    Default Re: Td5 not starting

    Stopped for half an hour but when leaving we found that no lights came on when turning the key. Checked all fuses and earthing without success. Tried jump starting also with no difference. Hooter works, brights and hazards work. No dim and no indicators.

    think you need to expand on the symptoms, the above is unclear.

  12. #12
    Join Date
    Sep 2018
    Location
    East London
    Posts
    84
    Thanked: 2

    Default Re: Td5 not starting

    Quote Originally Posted by RussellF View Post
    Stopped for half an hour but when leaving we found that no lights came on when turning the key. Checked all fuses and earthing without success. Tried jump starting also with no difference. Hooter works, brights and hazards work. No dim and no indicators.

    think you need to expand on the symptoms, the above is unclear.
    Basically the vehicle is stone dead. When turning the key in the ignition no dashboard lights come on.

  13. #13
    Join Date
    May 2014
    Location
    B-gowrie Randburg
    Age
    65
    Posts
    609
    Thanked: 244

    Default Re: Td5 not starting

    Check main feed to, and earthing line at rear of fuse/box under seat ... check temps there after trying to start etc
    If these lines not tight and effectively
    connected or high resistance etc screws can heat up or plastic surround even melt .

    I’m not nearly a Sparky but ...
    at start-up I see the heaviest battery loads as being starter, glowplugs and fuel pump ... a heavy combined initial load facilitated under the seat ...
    ... and , for TD5 the 4 glow plugs each draw up to 20A ...
    Last edited by BushNomad; 2019/12/30 at 10:21 AM.
    ... Land Rover Owners dont idle long ...

    2002 Defender 130 DC HCPU. : Own the road...Any road
    ‘1981 R-Rvr Classic 2-Dr 3.5L V8... The Greatest Rover.
    ‘1975 Series3 88 PUP... Simply Classic...
    ‘2017 Metalian Mini ... A Home from Home

    * The Monarch of the Glen *http://www.4x4community.co.za/forum/...1&d=1507751251

  14. #14
    Join Date
    May 2009
    Location
    Springs
    Age
    60
    Posts
    16,728
    Thanked: 277

    Default Re: Td5 not starting

    when switching on the ignition, can you hear the pump?
    start by bridging the ignition wires on the ignition switch.
    play musical chairs with the black relays
    after that do the same with the yellows.
    i would not worry about the glow plugs - that will cause hard starting - not dead as a doornail.

    Land Rovers never die, they simply become organ donors!

  15. #15
    Join Date
    Sep 2018
    Location
    East London
    Posts
    84
    Thanked: 2

    Default Re: Td5 not starting

    Hi all. Just got back. Wire had come off the glow plug and blew the 100A fuse under drivers seat. All now working. Thanks for all the advice.

  16. #16
    Join Date
    May 2009
    Location
    Springs
    Age
    60
    Posts
    16,728
    Thanked: 277

    Default Re: Td5 not starting

    Quote Originally Posted by Antrover View Post
    Hi all. Just got back. Wire had come off the glow plug and blew the 100A fuse under drivers seat. All now working. Thanks for all the advice.
    the 100 is the main fuse.
    confused why the 80A glowplug fuse did not pop first.
    if the main fuse did pop, it would be dead

    Land Rovers never die, they simply become organ donors!

  17. #17
    Join Date
    Sep 2018
    Location
    East London
    Posts
    84
    Thanked: 2

    Default Re: Td5 not starting

    Quote Originally Posted by Landyluvver View Post
    the 100 is the main fuse.
    confused why the 80A glowplug fuse did not pop first.
    if the main fuse did pop, it would be dead
    In the manual and on the fuse cover it shows the first fuse as being for the glow plugs and rated at 100A. At the moment we have made do with a 50A just to get home.

  18. #18
    Join Date
    Mar 2015
    Location
    New Germany
    Age
    49
    Posts
    1,141
    Thanked: 451

    Default Re: Td5 not starting

    Quote Originally Posted by Landyluvver View Post
    the 100 is the main fuse.
    confused why the 80A glowplug fuse did not pop first.
    if the main fuse did pop, it would be dead
    According to the wiring diagram the 100amp fuse provides power direct to glow plugs that why it blow, the 100 amp fuse also supplies power to the 20 amp switch column, 60 amp satalight fuse box, 60 amp relay ignition, 20amp socket wires30amp ABS relay
    that is why had no power as main 100 amp blew
    Attached Images Attached Images  
    Last edited by clivemd; 2019/12/30 at 09:09 PM.
    1995 300TDi Defender with VGT Turbo
    2002 Defender with LS1 MS3 ECU, 4L80e, LT230 1.222, Lockers and HD CW&P, 35" with 4" Lift

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •