Bubbles in my 4m40 radiator





Results 1 to 4 of 4
  1. #1
    Join Date
    Jul 2018
    Location
    Krugersdorp
    Age
    32
    Posts
    22
    Thanked: 1

    Default Bubbles in my 4m40 radiator

    Good evening im new to the 4x4 forum i recently bought a 2005 mitsubishi colt 2.8 tdi 4x4 amazing bakkie only problem i noticed recently it started using some water about 400ml every 600km i do alot of traffic driving. I noticed bubbles in the radiator nothing in the over flow bottle and the temp gauge doesnt go over half, bakkie starts perfectly every time has no loss of power and no coolant leaks that i can see. Please advise me, im hopeing its not the cylinder head

  2. #2
    Join Date
    Jun 2014
    Location
    Pretoria
    Age
    39
    Posts
    6
    Thanked: 1

    Default Re: Bubbles in my 4m40 radiator

    Hi There
    welcome I had a similar experience with my 2007 Ford ranger turned to be a cracked Cylinder head, check you exhaust if it is spewing out black water. hope you get it sorted.

  3. #3
    Join Date
    Nov 2009
    Location
    Richardsbay, KZN
    Age
    44
    Posts
    4,613
    Thanked: 7122

    Default Re: Bubbles in my 4m40 radiator

    Have a radiator shop do a "gas test" on the coolant system, done via the radiator cap. It will show combustion contamination of the water or not.

    Unfortunately these engines are prone to crack heads and the odds that your's has done the same is again, unfortunately quite possible.
    "Stare, pry, listen, eavesdrop. Die knowing something, you are not here long"
    Walker Evans, Photographer

  4. #4
    Join Date
    Jul 2018
    Location
    Krugersdorp
    Age
    32
    Posts
    22
    Thanked: 1

    Talking Re: Bubbles in my 4m40 radiator

    Thanks for the replies had silverton radiators in krugersdorp do a combustion test on my radiator today amd good news no gases in my radiator fitted a new cap a 1.1 bar cap he says i should flush my radiator and cooling system cause the previous owner might have put a flush in and not cleant it out properly. Any more advise please

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •