Discovery 4 in Mabuasehube





Results 1 to 20 of 37

Threaded View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    Apr 2013
    Location
    Hoedspruit
    Age
    31
    Posts
    241
    Thanked: 89

    Default Discovery 4 in Mabuasehube

    Hi Everyone

    We have just returned from a great time in Mabua and the South African side of the Kgalagadi. This was the first time with the D4 and what an experience it was.
    1) I have never experienced a vehicle that capable on the road getting there and also handling the soft sand.
    2) Learning the 'new' 4WD system was some getting used to.
    3) I only lowered the tyres to 2 bar in the front and 2.4 bar at the back. No issues whatsoever.
    4) As soon as we struck the thick sand after Tshabong the other vehicle in the party was ploughing with an off road caravan and it was decided that the Disco should tow. Again very capable.

    However 2 things to mention.

    1) I noticed the vehicle was very low one morning after our overnight stop in Vryburg on route to Mabua. I phoned around and was told to do a test the following evening to see where the air leak is. With the battery disconnected the vehicle only dropped its backside during the night. It was difficult to see if one side was leaning more. The following day I raised the suspension to Extended Off Road Hight with the lift rods and left the vehicle stationary for 2 days with the battery disconnected. 2 Evenings later and the vehicle was just as tall as I left it, not dropping an inch. I did the same exercise every day and noticed the car was leaning on the left back corner. I am assuming its an air bellow? Any thoughts as a lot of people tell me that the rear air bags hardly ever give problems.

    2) The second issue only started today. We left Pretoria and 30min into our drive back to Hoedspruit I noticed some harsh gear shifting. Later whilst being on cruise control the acted 'choppy and jerky', struggling to hold the gear. I went to command shift and all was good. I phoned Nico at ZF SA and he confirms that all the symptoms described sound like it needs an oil service with new oil and a filter. The car has 127 000km on the clock and has never had a gearbox service. I really hope that is the issue.

    Cheers

    Andre
    2011 Discovery 4 V8 HSE

  2. The Following 13 Users Say Thank You to Fourie110 For This Useful Post:


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •