2005 4x4 300 power issues





Results 1 to 13 of 13
  1. #1
    Join Date
    Jan 2015
    Location
    Farm near Jansenville EC
    Age
    43
    Posts
    94
    Thanked: 3

    Default 2005 4x4 300 power issues

    Hi all, my 300 go big 4x4 158000km is still giving me headaches, been struggling with this bakkie of my for a while now. She has always had a power issue, replaced the injectors at 150 000, didn't do much , she now is really pup on up hills, not to mention if I tow a trailor, she's fine around the farm, just on the open road she behaves like my old 2.5 4x4, EGR been blanked for a few years now, it's as if she's not getting enough diesel, now I've gone through this forum checking post with similar problems, my conclusion is TPS or MAF and worst case the diesel pump, I service her every 10000km, all filters, only use a GM Diesel filter, water trap fine, had her at GC Diesel last year on the dino machine, only putting out 68kw at the wheels, should be at least 75 or more, they said injectors or MAF, u see I live on a farm near Jansenville and this is my farm bakkie so don't often get to PE so when I do I want to take her to a honest reliable place that is not going to try make a quick buck like the Stealers do, a chap that actually knows these 300 bakkies issues, as I've seen on this forum there can be a small problem and they replace all the expensive parts and in the end it's a little problem that some old retired Oomie resolves due to his experiences and true knowledge of being a mechanic.
    So if anybody can help me connect with the right person I would be extremely grateful, I'm at wits end with van.

  2. #2
    Join Date
    Sep 2012
    Location
    johannersburg
    Age
    25
    Posts
    1,132
    Thanked: 31

    Default Re: 2005 4x4 300 power issues

    Quote Originally Posted by Charlton View Post
    Hi all, my 300 go big 4x4 158000km is still giving me headaches, been struggling with this bakkie of my for a while now. She has always had a power issue, replaced the injectors at 150 000, didn't do much , she now is really pup on up hills, not to mention if I tow a trailor, she's fine around the farm, just on the open road she behaves like my old 2.5 4x4, EGR been blanked for a few years now, it's as if she's not getting enough diesel, now I've gone through this forum checking post with similar problems, my conclusion is TPS or MAF and worst case the diesel pump, I service her every 10000km, all filters, only use a GM Diesel filter, water trap fine, had her at GC Diesel last year on the dino machine, only putting out 68kw at the wheels, should be at least 75 or more, they said injectors or MAF, u see I live on a farm near Jansenville and this is my farm bakkie so don't often get to PE so when I do I want to take her to a honest reliable place that is not going to try make a quick buck like the Stealers do, a chap that actually knows these 300 bakkies issues, as I've seen on this forum there can be a small problem and they replace all the expensive parts and in the end it's a little problem that some old retired Oomie resolves due to his experiences and true knowledge of being a mechanic.
    So if anybody can help me connect with the right person I would be extremely grateful, I'm at wits end with van.
    hi please check ur maf clean it with electric contact cleaner and also where did u block ur egr off also have u cleaned out the intercooler at all id recomend all this and a 63mm exhaust these motors can make about 400nms and 115kws if tuned properly
    ISUZU KB300LX DMAX mine / 1.4tdci with software exhaust and intercooler and watermeth injection /dad-kb300 dteq kb5 4x4 /uncle kb300 4x2 dteq kb5 /step dad. Kb6 kb300 4x4 auto all double cabs

  3. The Following User Says Thank You to giolanman For This Useful Post:


  4. #3
    Join Date
    Jan 2015
    Location
    Farm near Jansenville EC
    Age
    43
    Posts
    94
    Thanked: 3

    Default Re: 2005 4x4 300 power issues

    Quote Originally Posted by giolanman View Post
    hi please check ur maf clean it with electric contact cleaner and also where did u block ur egr off also have u cleaned out the intercooler at all id recomend all this and a 63mm exhaust these motors can make about 400nms and 115kws if tuned properly
    Thanx Giolanman
    Replaced the intercooler, have cleaned the MAF before, but didnt do much, I suppose the only way to know if its faulty is to borrow somebody else's one, the EGR , I blanked it at both sides with a blanking plates, removed that pipe that goes over the tappid cover and blocked the small rubber pipe that comes from the EGR solenoid(think thats whats it called), she just seems as if she's not getting enouph diesel, shes also heavy on diesel, 8/8.5 km per litre, is there no little sieve that goes in to the diesel pump from the Diesel filtre, my 2.5 compersator Go Big shape blocked there, only use 50ppm since Ive owned her.

  5. #4
    Join Date
    Aug 2016
    Location
    Bloemfontein
    Posts
    94
    Thanked: 16

    Default Re: 2005 4x4 300 power issues

    My brothers one did the same. On his one every "specialist" wanted to replace the pump. There was just no way I could see how you can just say replace the pump but no basics were checked. Wastegate turned out to be problem nr 1 as it was opening @ 0.4bar. Adjusted to 1bar.Now we had a worse problem whenever you tried getting full power from it you either had nothing or it started jerking. Traced this to the water trap that was blocked.He replaced the water trap filter and now back to normal. Remember though at the wheels you won't see close to the rated power. Not sure of the losses on the 4x4 but I'd be surprised if it had more than 75-80kw on the wheels. Also if you blocked the EGR, did you install an EGR fooler? Otherwise it will simply go into limp mode after 30 seconds of steady cruising.

  6. The Following User Says Thank You to _FC For This Useful Post:


  7. #5
    Join Date
    Aug 2011
    Location
    Brackenfell
    Age
    36
    Posts
    1,567
    Thanked: 226

    Default Re: 2005 4x4 300 power issues

    The water trap/filter under the passenger side on mine I changed. Have done plenty k's with new filter that replaced it.

    You remove the old water trap/filter housing and the plate surround as it won't fit the new filter. I installed a Z188 (from ford IIRC) and screw the water trap into the bottom of the filter top screw in exactly as per old. That became the first filter from the tank which I also replaced every service. Fairly cheap.

    by doing this you now have 2 filter (diesel) before the primer pump. One under vehicle and one at primer pump. Filter is slightly longer than the standard one, but you can fabricate a new protective cover to avoid the trap of being knocked by a stone and damage it.

    alternative option to replace the expensive GM filter/water trap

  8. The Following User Says Thank You to Dwayne P For This Useful Post:


  9. #6
    Join Date
    Mar 2008
    Location
    De Wildt
    Age
    57
    Posts
    34,879
    Thanked: 10022

    Default Re: 2005 4x4 300 power issues

    Maybe ask who you can take it to on the Eastern Cape area?

    https://www.4x4community.co.za/forum...8-Eastern-Cape

    Dirk lives in PE, he'll know who the best guys are.

    My opinion: turbo isn't spooling up so either the waste gate or the turbo is spanked. On the very outside, no feedback to the ECU regarding vacuum or boost.
    2012 Jeep Sahara Unlimited 3.6 V6
    Percivamus

  10. The Following User Says Thank You to jelo For This Useful Post:


  11. #7
    Join Date
    Sep 2012
    Location
    johannersburg
    Age
    25
    Posts
    1,132
    Thanked: 31

    Default Re: 2005 4x4 300 power issues

    Quote Originally Posted by Charlton View Post
    Thanx Giolanman
    Replaced the intercooler, have cleaned the MAF before, but didnt do much, I suppose the only way to know if its faulty is to borrow somebody else's one, the EGR , I blanked it at both sides with a blanking plates, removed that pipe that goes over the tappid cover and blocked the small rubber pipe that comes from the EGR solenoid(think thats whats it called), she just seems as if she's not getting enouph diesel, shes also heavy on diesel, 8/8.5 km per litre, is there no little sieve that goes in to the diesel pump from the Diesel filtre, my 2.5 compersator Go Big shape blocked there, only use 50ppm since Ive owned her.
    If u unplug maff do u get a engine light if u unplug and no light and the bakkie drives the same then its the maff also try 500ppm we run most of our isuzus on them no problems our one like yours has had about 95% of its 460k life n 500ppm no problem have u cleaned the air intake out at any point we found ours at 300k full of gunk
    ISUZU KB300LX DMAX mine / 1.4tdci with software exhaust and intercooler and watermeth injection /dad-kb300 dteq kb5 4x4 /uncle kb300 4x2 dteq kb5 /step dad. Kb6 kb300 4x4 auto all double cabs

  12. #8
    Join Date
    Jan 2015
    Location
    Farm near Jansenville EC
    Age
    43
    Posts
    94
    Thanked: 3

    Default Re: 2005 4x4 300 power issues

    Thanx guys for the help, have somewhere to start, Ive found and downloaded that EGR Fooling gadget, will have to have it made up by a auto electrician, now the water trap Ive replaced with a Z131(old isuzu diesel filter), will have the turbo check when I get to Pe again, want to check the MAF, but need that correct cleaner, will keep u posted.

  13. #9
    Join Date
    Jan 2015
    Location
    Farm near Jansenville EC
    Age
    43
    Posts
    94
    Thanked: 3

    Default Re: 2005 4x4 300 power issues

    Quote Originally Posted by giolanman View Post
    If u unplug maff do u get a engine light if u unplug and no light and the bakkie drives the same then its the maff also try 500ppm we run most of our isuzus on them no problems our one like yours has had about 95% of its 460k life n 500ppm no problem have u cleaned the air intake out at any point we found ours at 300k full of gunk
    Removed the plug wires of the MAF today and engine light comes on straight away, then lacks major power, connected and light goes off, I actually disconnected the air intake from the wheel arch as it sucks up to much dust, so air is coming from the engine bay, would like to fit a snorkel, have reconnected it and makes now difference

  14. #10
    Join Date
    Nov 2011
    Location
    East London
    Age
    52
    Posts
    180
    Thanked: 33

    Default Re: 2005 4x4 300 power issues

    Did you ever get this problem sorted?

  15. #11
    Join Date
    Apr 2018
    Location
    Cape Town
    Posts
    419
    Thanked: 151

    Default Re: 2005 4x4 300 power issues

    Does the GO Big have a Cat?
    2017 Isuzu KB 300 4X4 Auto (current)
    2008 Isuzu KB 300 4X4 manual (current)
    2017 Isuzu kB 250 (sold)
    2006 Isuzu KB300 (sold)
    2002 Isuzu Kb 260 petrol (sold)

  16. #12
    Join Date
    Mar 2014
    Location
    Marble Hall
    Age
    63
    Posts
    244
    Thanked: 17

    Default Re: 2005 4x4 300 power issues

    Charlton can you give more info on the EGR Fooling gadget as I also have the problem of limp mode and yellow engine light . Do you have a diagram with all the "magodies" to build one. Any help will be greatly appreciated .

  17. #13
    Join Date
    Jan 2015
    Location
    Farm near Jansenville EC
    Age
    43
    Posts
    94
    Thanked: 3

    Default Re: 2005 4x4 300 power issues

    Hi Ruger send me your email address and I can email you how to build the EGR gadget thingy, Im going to the auto electrician this week to have myne fitted.
    My no. 0822235074

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •