Discovery 1 Automatic Box not locking in Park?





Results 1 to 6 of 6
  1. #1
    Join Date
    May 2018
    Location
    Brisbane
    Posts
    45
    Thanked: 30

    Cool Automatic Box not locking in Park?

    Hi, I should have entitled this thread, "This never seems to end" or "The joys of owning a Land Rover?"

    Anyway, in my 98 Disco my Auto gearbox is sometimes failing to lock when I put it into Park. The car may roll with some clunking like the Park is semi engaged.
    I can live with the problem but because my wife also drives the car I can imagine the day when she forgets to engage the handbrake and the car goes careening into something or someone.

    Besides this issue, the box is performing perfectly well. Changes in gear are smooth and there appears to be no noises or malfunction.

    Does anyone know whether I can adjust 'something' easily or is this a real issue that can't be fixed without a rebuild??

    Thanks for anyone sharing knowledge.

  2. #2
    Join Date
    Mar 2008
    Location
    De Wildt
    Age
    57
    Posts
    37,465
    Thanked: 13635

    Default Re: Automatic Box not locking in Park?

    There is what they call the XYZ / PNPS switch but that is only for the D2 with the electronic box?

    You have a D1?

    I think it is linkages or shifter cable because the D1 has the manual box. But I'm no guru with that box. Sometimes apparently it's a coin or something that falls through from the top.
    2012 Jeep Sahara Unlimited 3.6 V6
    Percivamus

  3. The Following User Says Thank You to jelo For This Useful Post:


  4. #3
    Join Date
    May 2018
    Location
    Brisbane
    Posts
    45
    Thanked: 30

    Default Re: Automatic Box not locking in Park?

    Yea mine is a D1.
    Thanks
    I know little to nothing about Auto boxes. I 'thought' that the shifting was internal but if it's done via a cable maybe it's just an adjustment?? Maybe?

    Thanks I'll crawl under and check it out. I won't do anything yet though

  5. #4
    Join Date
    Mar 2008
    Location
    De Wildt
    Age
    57
    Posts
    37,465
    Thanked: 13635

    Default Re: Automatic Box not locking in Park?

    Quote Originally Posted by Peppercorn View Post
    Yea mine is a D1.
    Thanks
    I know little to nothing about Auto boxes. I 'thought' that the shifting was internal but if it's done via a cable maybe it's just an adjustment?? Maybe?

    Thanks I'll crawl under and check it out. I won't do anything yet though
    yes there is a cable and then a bunch of pins and linkages on the gearbox body: could just be a cable adjuster

    Maybe try find the D1 workshop manual off AULRO? The guys there are pretty keen to help.
    2012 Jeep Sahara Unlimited 3.6 V6
    Percivamus

  6. The Following User Says Thank You to jelo For This Useful Post:


  7. #5
    Join Date
    May 2018
    Location
    Brisbane
    Posts
    45
    Thanked: 30

    Default Re: Automatic Box not locking in Park?

    Thanks jello,

    I'll check it out as soon as I can get someone to sit in the drivers seat and move the Gear selector and I can crawl under.

    AULRO is full of great blokes as you say (I used to be one of them) but, I find the Moderator or owner of that site annoying as, because they moved to a 'pay per play forum' a few years back and I'm anti the entire premise of paying for access there.

    IMO the entire forum only exists because it was based on a free exchange of knowledge from mechanics and owners who's only incentive was to help other Land Rover owners. As the knowledge was accumulated and recorded, we were then told to pay or we got locked out. I personally added a few technical 'how to's' on that site over the years but then I got locked out.
    Even if I could afford to pay I wouldn't. You can call me cheap but I believe the motive to pay is wrong.

  8. #6
    Join Date
    Mar 2008
    Location
    De Wildt
    Age
    57
    Posts
    37,465
    Thanked: 13635

    Default Re: Automatic Box not locking in Park?

    Quote Originally Posted by Peppercorn View Post
    Thanks jello,

    I'll check it out as soon as I can get someone to sit in the drivers seat and move the Gear selector and I can crawl under.

    AULRO is full of great blokes as you say (I used to be one of them) but, I find the Moderator or owner of that site annoying as, because they moved to a 'pay per play forum' a few years back and I'm anti the entire premise of paying for access there.

    IMO the entire forum only exists because it was based on a free exchange of knowledge from mechanics and owners who's only incentive was to help other Land Rover owners. As the knowledge was accumulated and recorded, we were then told to pay or we got locked out. I personally added a few technical 'how to's' on that site over the years but then I got locked out.
    Even if I could afford to pay I wouldn't. You can call me cheap but I believe the motive to pay is wrong.
    yep, same reason why I'm not there any more, it might be Oz Dollars but it's still R10 to the AU$.............
    2012 Jeep Sahara Unlimited 3.6 V6
    Percivamus

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •