Problem witth solar panel - advice please




Results 1 to 12 of 12
  1. #1
    Join Date
    Sep 2011
    Location
    Johannesburg
    Age
    58
    Posts
    453
    Thanked: 44

    Default Problem witth solar panel - advice please

    Hi all,

    I installed a 100w 18v semi flex solar panel with a victron 75/15 mppt to charge the fridge deep cell battery when standing. Mppt worked but amp to the battery from the mppt never went above .4 amps.

    I got a 10amp multimeter to isolate the problem. Started with the solar panel. Isolated from the system the panel in good sunlight gave a reading of just over 18v but an amp reading of 0.87 amps whereas it shoul give a reading of at least 4-5 amps.

    What could be the problem? What should I check?

  2. #2
    Join Date
    May 2009
    Location
    Hillcrest, Malaysia
    Age
    62
    Posts
    18,261
    Thanked: 5387

    Default Re: Problem witth solar panel - advice please

    Quote Originally Posted by Roadman View Post
    Hi all,

    I installed a 100w 18v semi flex solar panel with a victron 75/15 mppt to charge the fridge deep cell battery when standing. Mppt worked but amp to the battery from the mppt never went above .4 amps.

    I got a 10amp multimeter to isolate the problem. Started with the solar panel. Isolated from the system the panel in good sunlight gave a reading of just over 18v but an amp reading of 0.87 amps whereas it shoul give a reading of at least 4-5 amps.

    What could be the problem? What should I check?
    How are you doing the amp reading. Between the panel and the MPPT (inline?), or short circuit across the PV panel pos and neg.
    Cheers

    ZS5KAD
    3 V8's
    NA TwinTurbo SuperCharger
    A V6 and an inline 4

    The frogs are starting to notice that the water is getting warm but it is already too hot to do anything about it.....

  3. #3
    Join Date
    Sep 2011
    Location
    Johannesburg
    Age
    58
    Posts
    453
    Thanked: 44

    Default Re: Problem witth solar panel - advice please

    Hi open circuit between the + and - of the panel leads for both the v and amp reading

  4. #4
    Join Date
    Feb 2011
    Location
    Kuilsrivier
    Age
    47
    Posts
    1,886
    Thanked: 98

    Default Re: Problem witth solar panel - advice please

    Well then, if the amp reading is between the solar panel leads only, then there is a fault with the solar panel.
    If the panel is new, rather take it back to the supplier.
    If not, you will have to look at the wiring at the panel terminal box.


    2007 Nissan Navara 4L Auto - Worshond


  5. #5
    Join Date
    Dec 2011
    Location
    Cape Town
    Age
    58
    Posts
    940
    Thanked: 76

    Default Re: Problem witth solar panel - advice please

    Amp meter must be series , in other words break the wire insert amp meter in line , reconnect, crocodile clips work as a temp connections

    Also amp meter readings only show if there is a load “drawing amps from the panel”

    If a battery is almost full the amp meter will show very little draw.

    Another test is to measure the voltage across the panel during a charge cycle, voltage will be less that the rated panel voltage

    Open circuit voltage is high (no load)

  6. #6
    Join Date
    Oct 2013
    Location
    Centurion
    Age
    62
    Posts
    611
    Thanked: 235

    Default Re: Problem witth solar panel - advice please

    Confirm you have read the volts and amps as per this drawing. In your case the panel is in the place of the battery. The voltmeter could also be directly on the + and - of the panel on the left with wires connected.
    Name:  ___Snap4794.jpg
Views: 238
Size:  6.4 KB
    Last edited by ekkekan; 2019/03/10 at 01:50 PM.

  7. #7
    Join Date
    Aug 2012
    Location
    Okahandja, Windhoek
    Age
    67
    Posts
    3,797
    Thanked: 625

    Default Re: Problem witth solar panel - advice please

    Quote Originally Posted by Roadman View Post
    Hi open circuit between the + and - of the panel leads for both the v and amp reading
    Was the tester correctly set for amps.
    Last edited by JLK; 2019/03/10 at 05:15 PM.
    Johan Kriel

    LC's and Echo Chobe

  8. #8
    Join Date
    Nov 2009
    Location
    Windhoek
    Age
    40
    Posts
    944
    Thanked: 131

    Default Problem witth solar panel - advice please

    Quote Originally Posted by Roadman View Post
    Hi open circuit between the + and - of the panel leads for both the v and amp reading
    Edit - Should give amps of short circuit amp rating of panel when connected directly to panel wires.

    Assume yours is normal wire type meter and not clamp. Most clamp amp meters can only measure AC amps. Dc clamp amp meters are around 1k and can then do only amps.

    What does the lights on 75/15 solar controller show? Float stage is green light blinking & yellow solid or both green & yellow solid on. Check your manual for explanation of lights. Amps are also very low when in float stage (battery fully charged) to only keep battery full. You want to meaure amps in bulk phase of charging.

    For measuring charge going to battery, Battery & controller needs to be connected with battery not full to have load on panel. Then insert amp meter in line of to measure amps on one line going going from controller to battery. Mppt controller can lower volt & up the amps going to battery. Should measure more amps on output side than on input side because if this.
    Last edited by BennvdmWhk; 2019/03/10 at 09:11 PM.
    Bennie van der Merwe
    Windhoek
    2007 Discovery 3 V8 SE
    Prev 2001 Pajero 3.2 DiD Lwb M/T

  9. #9
    Join Date
    Sep 2011
    Location
    Johannesburg
    Age
    58
    Posts
    453
    Thanked: 44

    Default Re: Problem witth solar panel - advice please

    Hi thanks for input. The problem with everything hooked up and on to a partly discharged battery - sitting at 12.44 volts at rest before starting (= bulk stage charging) and with panel in full sun victron mppt starts up fine - light a solid blue and bluetooth connect shows mppt at bulk stage charging but shows .2amps coming from the panel and .3 going to the battery.

    With the panel isolated voltage reading across the panel leads shows 18.4v max whereas it should be 21v (open circuit) and amps max .87. I removed the panel junction cover and tested the resistance across the two diodes - normal per youtube guide -reading .8 and reversed get the OL reading as expected. Tested voltage across the leads coming directly from the panel where soldered in the juntion box before the diodes- max 18.4v full sunlight midday as I say. Switched multimeter to 10a setting and put red lead into 10a slot on the meter and tested amps across the leads coming directly from the panel (in junction box) reading max .87 amps. No matter how I test just cannot get a reading using the multimeter above .87 amps or from bluetooth when system hooked up and running above .3amps never mind the at least 4-5 amps if not more that should be. I reckon there has been a failure of the panel - called the supplier, explained the findings and he indicated I can come in for a replacement panel. This time I will test the replacement panel before taking it. The way I understand it testing the panel across the panel leads in full sun I should get close to 21v and around 5 amps. If I do not get this from the replacement panel seems I should ask for another to test and keep going, if necessary until I get one with these readings. But please further comments and further advice is very welcome as I am on a major learning curve when it comes to a solar set up for the car.

  10. #10
    Join Date
    Aug 2012
    Location
    Okahandja, Windhoek
    Age
    67
    Posts
    3,797
    Thanked: 625

    Default Re: Problem witth solar panel - advice please

    You should get that reading about from the panels if measured over its terminals. Either the panel or the tester is faulty.
    Johan Kriel

    LC's and Echo Chobe

  11. #11
    Join Date
    Nov 2009
    Location
    Windhoek
    Age
    40
    Posts
    944
    Thanked: 131

    Default Re: Problem witth solar panel - advice please

    Agree with try new panel.

    You have smartsolar 75/15 version then, so 3 leds, 1 per stage or more details per BT app. Bluesolar 75/15 has only 2 leds and much harder to decipher without the manual or google.
    Bennie van der Merwe
    Windhoek
    2007 Discovery 3 V8 SE
    Prev 2001 Pajero 3.2 DiD Lwb M/T

  12. #12
    Join Date
    Oct 2013
    Location
    Centurion
    Age
    62
    Posts
    611
    Thanked: 235

    Default Re: Problem witth solar panel - advice please

    You could also test the panel with ammeter in place and shorting the ourput in early morning 10h or afternoon sun 15h and you should get 4A plus. This will show panel can deliver power. You could also buy a 24V car headlamp bulb of 55W and test if it lights up with existing panel and do the same with new panel.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •