Discovery 3 TDV6 random faults. Not able to start





Results 1 to 3 of 3
  1. #1
    Join Date
    Dec 2014
    Location
    Potchefstroom
    Age
    44
    Posts
    1
    Thanked: 0

    Default Discovery 3 TDV6 random faults. Not able to start

    Hi all,

    I have a 2009 TDV6 Discovery 3. I have had most of the normal D3 issues.
    From yesterday it started showing an fault message on the radio. System Shutting down Vehicle fault.
    While driving, the radio and climate control centre panel would then die, and the Instrument cluster would stop showing the time and ext temperature, which by my reckoning, is communicated from the centre radio and climate control console. But the engine does not cut out or go into limp mode.

    Once the fault appears, the hazards start flashing, but the indicators on the instrument cluster do not show up, neither do the lights for the headlamps, but the lights are on. While driving after about 5-10 minutes, everything would return back to normal.

    If you stop the vehicle while in the fault mode, you cannot get it started again. But it randomly clears the fault after a few minutes to an hour, and you can start the vehicle.

    Has anybody experienced similar problems?

    This guy seems to have the same problem, we checked the plugs at the back of the radio and climate control

    https://landroverforums.com/forum/lr...hutdown-88258/
    Last edited by PieterGeldenhuys; 2019/01/08 at 06:58 PM.

  2. #2
    Join Date
    Nov 2009
    Location
    Richardsbay, KZN
    Age
    44
    Posts
    4,538
    Thanked: 5985

    Default Re: Discovery 3 TDV6 random faults. Not able to start

    Pieter, ask in the Land Rover section, you will find more help there.
    "Stare, pry, listen, eavesdrop. Die knowing something, you are not here long"
    Walker Evans, Photographer

  3. #3
    Join Date
    Jul 2016
    Location
    Midrand
    Age
    47
    Posts
    977
    Thanked: 458

    Default Re: Discovery 3 TDV6 random faults. Not able to start

    Have you done a diagnostic? Have you checked sunroof drain not leaking onto BCU?

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •