Results 1 to 2 of 2
  1. #1
    Join Date
    Sep 2014
    Location
    Pretoria
    Age
    57
    Posts
    17
    Thanked: 5

    Default Tata Xenon 2.2 cambelt

    My truck’s cambelt broke. Put pins in the right holes for the timing ie the flywheel, the dieselpump, and the camshaft, and replaced the belt. I did not replace the radiator. The engine rotates but does not start. I also neglected to mark the position of the balancer.

    Any advice please.
    1972 Ford Escort 1600L-Swopped Mom for BMW below1978 BMW 518-Sold1981 BMW 518-Sold1985 Mazda 323 SLE-Sold1992 Mazda B2200-Sold1990 Audi 500-Sold1998 Ford Mondeo 2.0-Sold2001 Toyota Condor 2.4 RV-Sold2006 Mazda 3-Sold2005 Ssangyong Musso Sports-Sold2009 Tata Xenon 2.2 DLE DC-Sold2018 Renault Duster 1.5dCi 4x2-Gave to wife2005 SsangYong Musso Sports (yes the same one!)

  2. #2
    Join Date
    Jan 2013
    Location
    Pretoria
    Age
    26
    Posts
    947
    Thanked: 456

    Default Re: Tata Xenon 2.2 cambelt

    Does it have any compression.

    If it has compression. The camshaft can be one resolution out. Remove belt. Keep all the other pins in. Remove pin from camshaft. Turn it a full resolution. Refit belt. Turn engine by hand to make sure the pistons don't hit the valves. Try and start it again.

    If not then it might've bent valves if it is an interference motor. Don't know those engines.
    Last edited by JeandreDiedericks; 2018/10/06 at 09:45 PM.
    2005 Land Rover Discovery 3 V8
    1996 Land Rover Discovery 1 -VW Tdi Swap in Progress
    1967 Land Rover Series 2A 4.0 V8
    196? Land Rover Series 2 V8 100"
    2010 Range Rover Sport SC 5.0 V8

    Ex.
    Discovery 1:TDI and a V8. 2x Discovery 2 V8. 2X Discovery 3 TDV6. Freelander 2 TD4, 2X C350 CDI's, Subaru Forester XT and a Volvo V60 T6


Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
  •