Overcharge? NL monitor beep on Flexopower+D250SA




Results 1 to 15 of 15
  1. #1
    Join Date
    Jun 2012
    Location
    Centurion
    Age
    54
    Posts
    1,153
    Thanked: 185

    Default Overcharge? NL monitor beep on Flexopower+D250SA

    I have a Flexopower 3 panel set, 238W to catch sun.
    Goes via D250SA to dual batteries. At the time of my test the batteries are not depleted much, in fact pretty full.
    After a short while, my NL battery monitor starts beeping, indicating I suspect over-voltage.
    This happens even when I use only a single panel.

    There is no other power source active at the same time.
    The NL should start beeping at 14.65+ volts
    The D250SA should max out at 14.4v, unless the AGM wire is coupled to earth. It is not.

    I don't want to just disable the NL alarm function.

    Any ideas?
    Make it happen!

    2018 Mobi Lodge

  2. #2
    Join Date
    Jul 2012
    Location
    Wartburg
    Age
    58
    Posts
    922
    Thanked: 539

    Default Re: Overcharge? NL monitor beep on Flexopower+D250SA

    Check your actual voltage. The National Lunar battery monitor which I had in my Defender also swore at me every time the battery reached full capacity via the old CTEK charger. The voltage readings were fine, but the alarm setting was not. The most used button was the the mute button on the monitor


  3. #3
    Join Date
    Aug 2012
    Location
    Okahandja, Windhoek
    Age
    66
    Posts
    3,401
    Thanked: 436

    Default Re: Overcharge? NL monitor beep on Flexopower+D250SA

    Not sure if this is the case , but older NL monitors could not go to the 14.7 or what ever these DC chargers do charge.
    Johan Kriel

    LC PU's and a Prado

  4. The Following User Says Thank You to JLK For This Useful Post:


  5. #4
    Join Date
    Oct 2009
    Location
    Stellenbosch
    Age
    68
    Posts
    3,929
    Thanked: 460

    Default Re: Overcharge? NL monitor beep on Flexopower+D250SA

    I would do as mikeml suggested.
    Get an accurate reading of the actual charge voltage before you make any conclusions.
    Eggie.

    What this country needs more and more, are more unemployed politicians.
    - apology to Edward Langley.

  6. #5
    Join Date
    Jun 2012
    Location
    Centurion
    Age
    54
    Posts
    1,153
    Thanked: 185

    Default Re: Overcharge? NL monitor beep on Flexopower+D250SA

    Thanks guys - I'll do that. I assume I measure on battery (+OUT) and earth (-), the two terminals on the rhs of the D250SA?

    (p7 of https://www.autoelec.com.au/assets/b...nual-UK-EN.pdf)
    Make it happen!

    2018 Mobi Lodge

  7. #6
    Join Date
    Oct 2009
    Location
    Stellenbosch
    Age
    68
    Posts
    3,929
    Thanked: 460

    Default Re: Overcharge? NL monitor beep on Flexopower+D250SA

    Quote Originally Posted by Toccata (Roelof) View Post
    Thanks guys - I'll do that. I assume I measure on battery (+OUT) and earth (-), the two terminals on the rhs of the D250SA?

    (p7 of https://www.autoelec.com.au/assets/b...nual-UK-EN.pdf)

    Perhaps simplest is to measure on the utility battery poles.
    Either that or on the D250S (RHS) terminals as you mentioned.
    Eggie.

    What this country needs more and more, are more unemployed politicians.
    - apology to Edward Langley.

  8. #7
    Join Date
    Oct 2011
    Location
    Kempton Park
    Age
    69
    Posts
    103
    Thanked: 16

    Default Re: Overcharge? NL monitor beep on Flexopower+D250SA

    Thanks for this thread.

    I have had the same issues of NL monitor alarm on both caravan and vehicle mounted CtekD250S.

    I have a 50 watt solar panel on carport roof to keep the caravan batteries charged. This morning I entered the van and found the NL monitor screaming blue murder with the voltage reading 14.8v. with no load. See attached image.

    Disconnected the Ctek and coupled 2x120watt panels and Victron75/115, readings now normal and after a few minutes settled at 13.7v.

    Reconnected with above panels to Ctek, same results, immediately to 14.8v.

    Removed Ctek and dumped in the bin .

    What should I replace it with: WRND or just straight charging from vehicles alternator.
    Attached Images Attached Images  

  9. #8
    Join Date
    Feb 2010
    Location
    Wartburg.
    Age
    36
    Posts
    1,462
    Thanked: 247

    Default Re: Overcharge? NL monitor beep on Flexopower+D250SA

    Sorry, can't answer you.

    But do you perhaps want to sell the Ctec 250?
    I will be interested.

    Toyota Land Cruiser 79 DC V8
    Toyota Hilux 2.8 GD6 4x4
    Toyota RAV-4 2.2 D4D

  10. #9
    Join Date
    Jun 2012
    Location
    Centurion
    Age
    54
    Posts
    1,153
    Thanked: 185

    Default Re: Overcharge? NL monitor beep on Flexopower+D250SA

    Quote Originally Posted by jobro View Post
    I have had the same issues of NL monitor alarm on both caravan and vehicle mounted CtekD250S.
    Hi Jobro,
    your photo looks like Mobilodge panel? Was this fitted aftermarket? I think it may be worth getting similar on my side.
    Make it happen!

    2018 Mobi Lodge

  11. #10
    Join Date
    Oct 2011
    Location
    Kempton Park
    Age
    69
    Posts
    103
    Thanked: 16

    Default Re: Overcharge? NL monitor beep on Flexopower+D250SA

    Yes, I got the voltmeter from 4x4 Direct.
    Last edited by jobro; 2018/07/28 at 06:23 PM.

  12. #11
    Join Date
    Feb 2010
    Location
    Centurion
    Age
    54
    Posts
    2,145
    Thanked: 182

    Default Re: Overcharge? NL monitor beep on Flexopower+D250SA

    Quote Originally Posted by jobro View Post
    What should I replace it with: WRND or just straight charging from vehicles alternator.
    New National Luna DC-DC or one of the Redarc options. (Love my Manager 30)

  13. #12
    Join Date
    Dec 2013
    Location
    Pietermaritzburg
    Age
    52
    Posts
    356
    Thanked: 41

    Default Re: Overcharge? NL monitor beep on Flexopower+D250SA

    Interested here as I have NL box and just bought a flexopower Mojave to top up with.
    Havent tried it yet.

    They mention somewhere having a load on the battery during charging (i think) would that make a difference?
    Pajero Sport 2013 3.2 A/T

  14. #13
    Join Date
    Jun 2012
    Location
    Centurion
    Age
    54
    Posts
    1,153
    Thanked: 185

    Default Re: Overcharge? NL monitor beep on Flexopower+D250SA

    I had some discussion with a representative for CTEK, and with a few other people.
    CTEK stated that when ambnient temperature is low, the 250SA will up the voltage.
    I checked the manual; there is indeed some mention but no proper discussion of that.

    Also when I tested, the batteries were still fairly fully charged via 220v, which seems to go to a higher voltage than panels charging.

    We camped at Blouberg this past long weekend (with an extra day on both sides), and the voltage never climbed so high to cause the NL to start swearing at us.

    I also spoke to 2 camping and 4x4 vendors, who could not report any previous issues with the D250S(A).

    Case closed for me.
    Make it happen!

    2018 Mobi Lodge

  15. The Following User Says Thank You to Toccata (Roelof) For This Useful Post:


  16. #14
    Join Date
    Oct 2013
    Location
    Centurion
    Age
    62
    Posts
    99
    Thanked: 17

    Default Re: Overcharge? NL monitor beep on Flexopower+D250SA

    I take it as normal during the charging cycle. Even when charging from a car alternator with no lights on my NL battery monotor would give an alarm. Most intelligent chargers would charge over the upper limit to give an alarm. Once the battery is fully charged the voltage does come down. Actually annoying to have to constantly silence the NL bat monitor.

    In order to still use the NL bat monitor I would just reduce the voltage it sees with about 0.6V and add it to the reading it displays.
    Last edited by ekkekan; 2018/08/19 at 09:16 PM.

  17. #15
    Join Date
    Dec 2013
    Location
    Pietermaritzburg
    Age
    52
    Posts
    356
    Thanked: 41

    Default Re: Overcharge? NL monitor beep on Flexopower+D250SA

    Pulled out my new Mojave 120 this weekend to test it.
    Plugged in and it works pretty well, I am no sparky and I couldn't get a amp reading due to having fried my meter last month.
    But I note the Nat Luna goes "top o the green" 14.8v when it is plugged in and charging, which I like, as the car charger doesnt get that high.
    (Hope the MPPT is intelligent and drops to a trickle when fully charged.)

    Note with some irritation that the new Mojve kit shown on the website comes with a different MPPT to the one I bought a month ago.

    So the paranoia kicks in and now I worry the original one wasn't good, hence the replacement............

    This one is a bit fancier, as it has a LCD display so I guess it tells you what volts and amps it is running - useful. But it looks a bit plastic whereas the one I got is simple but solid feel.

    Price jumped R2000 since I bought There goes the Rand........
    Pajero Sport 2013 3.2 A/T

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •