Brakes not releasing immediately?





Results 1 to 9 of 9
  1. #1
    Join Date
    Aug 2008
    Location
    Rangeview Krugersdorp
    Age
    69
    Posts
    6,027
    Thanked: 901

    Default Brakes not releasing immediately?

    Chev Aveo auto and I have noticed this last week only after having the car for 4 months that the brakes seem to release only after a few seconds of taking the foot off the pedal?

    Does not happen all the time, perhaps 2 in 10 times of braking. Seems as if the pads are sticking to the discs?

    Happened to my Tucson auto as well occasionally.

    Wheels are cleaned and hosed off in car wash weekly.

    Pads are in good condition, more than 50% life left. Discs have no wear or ridges. No potholes have been hit lately.

    Nothing has changed recently that I can think of as a cause.

    Thanks guys.
    There is no task too simple for some people to complicate !



    Chev Aveo and Atos and Polo.

  2. #2
    Join Date
    Jun 2014
    Location
    George
    Posts
    2,473
    Thanked: 855

    Default Re: Brakes not releasing immediately?

    First make sure the brakes aren't binding on any of the wheels, jack them up and spin by hand and also I'd flush the brake fluid if the vehicle was bought 2hnd, very easy to do and only cost around R150 in fluid.

  3. The Following User Says Thank You to Skylark For This Useful Post:


  4. #3
    Join Date
    Aug 2015
    Location
    Howick
    Age
    39
    Posts
    160
    Thanked: 29

    Default Re: Brakes not releasing immediately?

    Are you sure you model doesn't have hill start assist?

  5. #4
    Join Date
    Aug 2008
    Location
    Rangeview Krugersdorp
    Age
    69
    Posts
    6,027
    Thanked: 901

    Default Re: Brakes not releasing immediately?

    Quote Originally Posted by Gav.S View Post
    Are you sure you model doesn't have hill start assist?
    Not a clue ?
    There is no task too simple for some people to complicate !



    Chev Aveo and Atos and Polo.

  6. #5
    Join Date
    Aug 2015
    Location
    Howick
    Age
    39
    Posts
    160
    Thanked: 29

    Default Re: Brakes not releasing immediately?

    Does it have an electronic handbrake or an old style lever handbrake?

  7. #6
    Join Date
    Aug 2008
    Location
    Rangeview Krugersdorp
    Age
    69
    Posts
    6,027
    Thanked: 901

    Default Re: Brakes not releasing immediately?

    Quote Originally Posted by Gav.S View Post
    Does it have an electronic handbrake or an old style lever handbrake?
    Ordinary handbrake between seats.
    There is no task too simple for some people to complicate !



    Chev Aveo and Atos and Polo.

  8. #7
    Join Date
    Aug 2008
    Location
    Rangeview Krugersdorp
    Age
    69
    Posts
    6,027
    Thanked: 901

    Default Re: Brakes not releasing immediately?

    Remember it is something that has just started. Mileage is 90k
    There is no task too simple for some people to complicate !



    Chev Aveo and Atos and Polo.

  9. #8
    Join Date
    Apr 2010
    Location
    Garsfontein
    Age
    40
    Posts
    1,267
    Thanked: 475

    Default Re: Brakes not releasing immediately?

    Quote Originally Posted by duncang View Post
    Not a clue ?
    First you figure that out then... or didn't it always do that?

  10. #9
    Join Date
    Jun 2009
    Location
    Greyton westerncape
    Age
    66
    Posts
    686
    Thanked: 35

    Exclamation Re: Brakes not releasing immediately?

    Brake hoses swollen inside due to old incorrect fluid.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •