Results 1 to 3 of 3
  1. #1
    Join Date
    Jul 2017
    Location
    Cape Town
    Age
    46
    Posts
    31
    Thanked: 1

    Question Kia Sorento Injector issue?

    Hi guys. I have a 2007 Kia Sorento 2,5CRDi EX. 210K on the clock. A while back an issue started, when parked facing upwards on an incline, starting would result in a puff of white smoke and the vehicle would idle really roughly for a little while but then would come right. A friend of mine is using the vehicle and since then the problem has become worse. It does it on start up, when stuck in traffic and when doing 8oKph. Prior to this we had an issue with a the intercooler pipe which cracked and was replaced (not properly resulting in loss of power etc- and it came loose on a long road trip but we found that and had it refitted properly). So I'm not sure whether it has anything to do with that. Various searches have pointed me to things starting from the glo plugs- it's winter in CPT so I started wondering about that, which have never been replaced, the EGR valve, and of course the injectors. I'm sending it to a place called DieselWorx CPT (anyone heard of them?) but if there is any sage advice on this vehicle or where I should start, that would be fantastic!

  2. #2
    Join Date
    Jul 2007
    Location
    Putfontein, Benoni
    Age
    56
    Posts
    2,836
    Thanked: 2034

    Default Re: Kia Sorento Injector issue?

    glow plugs work on startup only. So if it smokes while hot and running it is not glow plug. You still might have a glow plug issue but it is not causing the issue while driving....
    Audi Q7 - 3l TDi - 2013 - touring car
    VW Touareg - 2005 - V10 TDI ( tow car)
    VW Touareg - 2006 - V6 TDI - play car/ wife daily
    VW Touareg - 2013 - V8 TDI - my daily beast.

  3. #3
    Join Date
    Jul 2017
    Location
    Cape Town
    Age
    46
    Posts
    31
    Thanked: 1

    Default Re: Kia Sorento Injector issue?

    Quote Originally Posted by Stephan van Tonder View Post
    glow plugs work on startup only. So if it smokes while hot and running it is not glow plug. You still might have a glow plug issue but it is not causing the issue while driving....
    Thanks Stephan.
    Injectors have just been done by Dieselworx Cape Town. My mate has the vehicle and he juts sent me a video of the car on start up, white smoke everywhere and it sounds like it's running on 3 cylinders. I am currently out of town and it's driving me a bit crazy trying to figure it out as I'm not there.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
  •