Diesel Start and low speed problem





Results 1 to 4 of 4
  1. #1
    Join Date
    Dec 2011
    Location
    Cape Town
    Age
    59
    Posts
    955
    Thanked: 90

    Default Diesel Start and low speed problem

    Hope someone can assist or point me in the right direction.
    Our business Van a Fiat Fiorino 1.3 multijet turbo diesel has an issue.
    First the glow plug warning light has been on for awhile , an Indie cleared the fault but it comes back.

    I did call the dealer at first but because starting is first time, the thinking was it's a comms issue and have it sorted at next service, admittedly the dealer wasn't exactly helpful and wanted money up front to order a glow-plug

    Until recently, on some mornings there is a cloud of white smoke on cold start but it starts first time, during the day nothing on its daily run.

    However after the morning smoke issue, intermittently the van struggles a bit but not always on pull away till you hit 4th gear it hesitates basically at low revs under 2000RPM, on the high way plenty of power , hills no problem if you put the foot down.

    I sent the van to our local mech who services the basics and they sent it away , but no fault pops up on on diagnostic , the did find one dirty glow plug, which they cleaned, this helped but the problem returned a day later.

    Thinking I must send to dealer to have checked,
    Any thought from the diesel guys here would appreciate a 2nd opinion?

    Thanks
    Allen

  2. #2
    Join Date
    Jan 2017
    Location
    alberton
    Posts
    20
    Thanked: 7

    Default Re: Diesel Start and low speed problem

    Hi Allen,

    Your problem sounds similar to a fault I had on my ford fiesta before.Does it also have a bit of a rough idle at start up?

    What I did was to replace all 4 glow plugs wich resolved my problems and you saying that there was a error for this already would be my starting point.They should be relatively cheap and are easy enough to replace on your own or for your mechanic to do, but you say that he cleaned the glow plugs? I may be wrong but from what I learnt while doing my car is that the glow plugs dont need to be cleaned because they just burn anything off that gets on them during startup I could be mistaken on this though.

    I do know that you need a multimeter to test them though and there is a resistance range that they should fall into to still be ok.you will need to have a google to see exactly what that is for your particular glow plugs.

    On my car i found that 3 of the 4 glow plugs were completely out of range or providing a full short wich wasn't good.so it was actually only starting on one good glow plug.

    This is just my personal experience and based on very little experience but what you describe sounds similar to what I had hope you get it sorted out easy and some one with some more experience can assist you further.

  3. The Following User Says Thank You to Mud bug For This Useful Post:


  4. #3
    Join Date
    Dec 2011
    Location
    Cape Town
    Age
    59
    Posts
    955
    Thanked: 90

    Default Re: Diesel Start and low speed problem

    Appreciate the reply,
    will consider doing that as it might be the cheapest, although there is only 73000 km on the clock.

  5. #4
    Join Date
    Dec 2011
    Location
    Cape Town
    Age
    59
    Posts
    955
    Thanked: 90

    Default Re: Diesel Start and low speed problem

    Some feedback....
    Sent Van to the dealers , and was told our fuel is contributing to carbon/tar build up on the EGR valve

    They had the vehicle for two days and couldn't find any fault, so they decided to clean the valve, and suggested a new one if problems persist.

    Vehicle still not 100% but maybe new EGR would solve the issues.
    Still low on power not as nippy as it was.
    But at least I'm not getting the same hesitation/jerking.

    What I've noticed I can't feel the turbo kick as before (like when new), still a bit noisier than I'm used to.
    And still white smoke in the early morning first start.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •