Ford/Mazda Problems! - Page 7





Page 7 of 7 FirstFirst 1 2 3 4 5 6 7
Results 121 to 129 of 129
  1. #121
    Join Date
    Aug 2015
    Location
    Kraaifontein
    Age
    38
    Posts
    55
    Thanked: 18

    Default Re: Ford/Mazda Problems!

    Model: T6 3.2 Supercab 4x2
    Year: 2012
    Mileage: 133000
    Problem: Intercooler and boost pipe burst
    Cause of problem(if known): Actuator stuck on turbe
    Specifics of repair work carried out: Replace intercooler, boost pipe and overhaul turbo
    Cost of repair: R20 020
    Who did the repair: Motolek - Stikland
    Vehicle under warranty, Y/N: Aftermarket warranty
    Was damage covered by warranty: R10 000
    Brynmor

    2014 Ford Ranger 3.2 Extracab 4x2
    2012 Ford Ranger 3.2 Extracab 4x2 (Sold)

    2009 Mazda BT50 3.0 Extracab 4x2 (Sold)

  2. #122
    Join Date
    Mar 2013
    Location
    Centurion
    Age
    35
    Posts
    9
    Thanked: 7

    Default Re: Ford/Mazda Problems!

    Model: T7 2.2 XL Double Cab 4x4
    Year: 2016
    Mileage: 44000
    Problem: 1. Turbo being replaced for the second time in a period of a month.
    Glow plug failure
    Cause of problem(if known):
    Specifics of repair work carried out: Turbo and glow plugs replaced
    Cost of repair:
    Who did the repair: Motolek - Lazarus Ford Centurion
    Vehicle under warranty, Y/N: Y
    2008 Mitsubishi Triton 2.5 did 4x4 *Sold*
    2012 Mitsubishi Pajero Sport M/T *Sold*
    2016 Ford Ranger XL DC 4x4

  3. #123
    Join Date
    Dec 2010
    Location
    Meyerton
    Age
    62
    Posts
    267
    Thanked: 110

    Default Re: Ford/Mazda Problems!

    Model: T6 Ranger Supercab
    Year: 2017
    Mileage: 39994
    Problem: Funny repeating noise under dashboard even with ignition off and key removed.
    Cause of problem(if known): Stepper motor on venting system not going to home position when switched off.
    Specifics of repair work carried out: replace stepper motor.
    Cost of repair:+/- R980.00
    Who did the repair: Alberton Ford
    Vehicle under warranty, Y/N: Y
    Was damage covered by warranty: Replaced under service warranty
    Ford Ranger 2.2 Supercab
    Suzuki Jimny -SWAMBO
    Merida 29'r for fun and pain.

  4. #124
    Join Date
    Jul 2009
    Location
    Gauteng
    Age
    51
    Posts
    1,027
    Thanked: 885

    Default Re: Ford/Mazda Problems!

    Model: Everest 2.2 4x4 XLS
    Year: 2018
    Mileage: 8405
    Problem: Squeaky clutch
    Cause of problem(if known): Apparently warn and failed Nylon Bushes
    Specifics of repair work carried out: Replaced Clutch cage assembly
    Cost of repair: 0
    Who did the repair: Eagle Ford
    Vehicle under warranty, Y/N: Y
    Was damage covered by warranty: Yes

  5. #125
    Join Date
    Jan 2019
    Location
    Mkuze
    Posts
    11
    Thanked: 0

    Default Re: Ford/Mazda Problems!

    Model: 3.2 Auto 4x4
    Year: 2012
    Mileage: 125 000
    Problem: locking rear wheels after standing for a while.
    Cause of problem(if known):
    Specifics of repair work carried out:
    Cost of repair:
    Who did the repair:
    Vehicle under warranty, Y/N:
    Was damage covered by warranty:

    Hi there, looking for advice. I live and work on a Game Reserve, in more recent months after my car has been left standing as it has done previously, when I initially start the car and try reverse the car will not move, I have to give it quite a lot of power and then finally after a huge Clunk (from what seems to be back wheels or the rear of the car) so this problem only started after I got new shocks fitted, the place messed up the install and ruined a sensor on the front wheel and clearly didnít know what they are doing because they kept booking my car up to the computer and the guy kept trying to bleed brakes :-/ after fighting with them he stopped.. and after getting someone out the realized they broke the ABS sensor. It has been replaced but not the above has begun to be a problem... Any advice would be appreciated, I do have a video of it..

  6. #126
    Join Date
    Oct 2010
    Location
    Pretoria
    Age
    49
    Posts
    64
    Thanked: 16

    Default Re: Ford/Mazda Problems!

    Model: 3.0 CRDi 4x4 d/c
    Year: 2009
    Mileage: 177 960km
    Problem: Aircon not cooling air
    Cause of problem(if known): Aircon compressor head unserviceable
    Specifics of repair work carried out: Replaced aircon compressor with new unit
    Cost of repair: R5 500
    Who did the repair: Aircon cars cc
    Vehicle under warranty, Y/N: No
    Was damage covered by warranty: No

    Model: 3.0 CRDi 4x4 d/c
    Year: 2009
    Mileage: 186 580km
    Problem: Gear lever refuse to go over to 1st & 2nd gear.
    Cause of problem(if known): Selector (s) broken
    Specifics of repair work carried out: Replaced with new selector assembly.
    Cost of repair: R4 500
    Who did the repair: A2Z Gearbox & Diff, steve Biko St, Pretoria.

    Vehicle under warranty, Y/N: No
    Was damage covered by warranty: No

    Model: 3.0 CRDi 4x4 d/c
    Year: 2009
    Mileage: 223 380km
    Problem: Clutch not engaging every time its depressed. Struggles to change gears. Not slipping at all.
    Cause of problem(if known): Dual mass flywheel unserviceable
    Specifics of repair work carried out: Lock, skim & balanced old flywheel. Replaced clutch with new clutch kit.
    Cost of repair: R10 250
    Who did the repair: XLint Mechanical Maintenance, Moot St, Pretoria.
    Vehicle under warranty, Y/N: No
    Was damage covered by warranty: No
    Last edited by Spiceman; 2019/04/22 at 02:14 PM.
    Current - 2009 Mazda BT50 3.0CRDi 4x4 d/c
    Previous - 2005 Ranger 2.5 tdi 4x2 d/c (277 422km)

  7. #127
    Join Date
    Mar 2019
    Location
    Northern cape
    Age
    39
    Posts
    6
    Thanked: 0

    Default Re: Ford/Mazda Problems!

    Hi ive got a 2005 ford ranger 4.0 v6. My vehicle is 4x4 and ive had 2 4.0 v6s before this one and they were 2x4. So i know its a v6 and you cant expect a very good fuel consumption but, this is very heavy on fuel and it havent got the power that i know it should have. Please can anyone give me good advice because i tested the fuel pump and its giving 3 bar. Replaced plugs air filter and fuel filter. It still gives low fuel pressure on the diagnostic. What and where can i do to help me.

  8. #128
    Join Date
    Aug 2019
    Location
    Okahandja
    Posts
    1
    Thanked: 0

    Default Re: Ford/Mazda Problems!

    Hi Guys, 2008 Ford Ranger 2.5 since 22 Aug 2019 REALLY struggling to start when cold. Glow plugs 2 months old, serviced 4500km ago.
    What can be the problem?

  9. #129
    Join Date
    Aug 2014
    Location
    Maputo
    Age
    26
    Posts
    424
    Thanked: 18

    Default Re: Ford/Mazda Problems!

    Quote Originally Posted by CalvinRanger3.2 View Post
    Model: 3.2 Auto 4x4
    Year: 2012
    Mileage: 125 000
    Problem: locking rear wheels after standing for a while.
    Cause of problem(if known):
    Specifics of repair work carried out:
    Cost of repair:
    Who did the repair:
    Vehicle under warranty, Y/N:
    Was damage covered by warranty:

    Hi there, looking for advice. I live and work on a Game Reserve, in more recent months after my car has been left standing as it has done previously, when I initially start the car and try reverse the car will not move, I have to give it quite a lot of power and then finally after a huge Clunk (from what seems to be back wheels or the rear of the car) so this problem only started after I got new shocks fitted, the place messed up the install and ruined a sensor on the front wheel and clearly didnít know what they are doing because they kept booking my car up to the computer and the guy kept trying to bleed brakes :-/ after fighting with them he stopped.. and after getting someone out the realized they broke the ABS sensor. It has been replaced but not the above has begun to be a problem... Any advice would be appreciated, I do have a video of it..
    Usually hand brake and drums holding, when I stop mine for long periods I keep the hand brake off.

    Mine is an automatic so I keep it it park
    Heike Pinto,

    - 2014 Mazda BT-50 3.2TD 4x4 AT
    3" Exhaust | iDrive | HDi Intercooler Upgrade | Forefront Industries Alloy Boost pipes | Hybrid Turbo | 30% Nozzles | K&N Air Filter
    Fuel Injection Technology ECU Tune


    -2009 Isuzu Dmax 3.0 TD 4x4 MT

    Maputo, Mozambique

Page 7 of 7 FirstFirst 1 2 3 4 5 6 7

Similar Threads

  1. Toyota Problems!
    By Barto in forum Toyota
    Replies: 142
    Last Post: Today, 08:58 AM
  2. Isuzu Problems!
    By Barto in forum Isuzu
    Replies: 45
    Last Post: 2018/07/13, 07:29 PM
  3. Hummer Problems!
    By Barto in forum Hummer
    Replies: 2
    Last Post: 2017/12/04, 09:18 AM
  4. Conqueror Companion: Dream becomes nightmare
    By Alta in forum Camping, Fridges, Accessories
    Replies: 117
    Last Post: 2012/10/21, 09:54 PM
  5. Discovery 3 CD and Cruise Control problems (incl. bad experience with dealer)
    By ReadySteadyGo in forum Land Rover
    Replies: 8
    Last Post: 2011/11/09, 07:40 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •