Help please with my Ranger





Results 1 to 8 of 8
  1. #1
    Join Date
    Jun 2015
    Location
    Port Elizabeth
    Age
    30
    Posts
    10
    Thanked: 0

    Default Help please with my Ranger

    Hey guys, I've bought a 2007 ford ranger clubcab 2500td, had it for a couple days now and have noticed that the vehicle does not start too easy when the vehicle has been standing for a while eg in the morning. First start usually doesn't take and second try does. When it does start then the idle is very rough for about a minute and then its smooth and drives fine after that.

    Any advice on the issue?
    I'm a newbie to bakkies and this site, sorry if I have done something wrong.

  2. #2
    Join Date
    Jun 2015
    Location
    Port Elizabeth
    Age
    30
    Posts
    10
    Thanked: 0

    Default

    Oh yes I forgot to say, the vehicle is on 140000km and the injectors were done at 100000km

  3. #3
    Join Date
    Apr 2007
    Location
    Nigel
    Age
    58
    Posts
    15,812
    Thanked: 2078

    Default

    Glowplugs.
    LC 78 Troopie 1HD-FTE
    Uniglide
    +27 zero eight 2 four 95 9252

  4. #4
    Join Date
    Aug 2009
    Location
    Alberton
    Age
    40
    Posts
    1,239
    Thanked: 83

    Default

    Yep, glow plugs. So when it does start it rumbles a bit and once warm its happy? Def glow plugs ;-)

  5. #5
    Join Date
    Sep 2008
    Location
    Vanderbijlpark
    Age
    50
    Posts
    1,799
    Thanked: 180

    Default

    Quote Originally Posted by ozosborne View Post
    Yep, glow plugs. So when it does start it rumbles a bit and once warm its happy? Def glow plugs ;-)
    +1
    ZS6VL


  6. #6
    Join Date
    Oct 2008
    Location
    Langebaan
    Age
    36
    Posts
    359
    Thanked: 31

    Default

    Quote Originally Posted by Jaysonjay View Post
    Hey guys, I've bought a 2007 ford ranger clubcab 2500td, had it for a couple days now and have noticed that the vehicle does not start too easy when the vehicle has been standing for a while eg in the morning. First start usually doesn't take and second try does. When it does start then the idle is very rough for about a minute and then its smooth and drives fine after that.

    Any advice on the issue?
    I'm a newbie to bakkies and this site, sorry if I have done something wrong.
    Jip..glowplugs. Mine did the same. Quick fix.

  7. #7
    Join Date
    Dec 2008
    Location
    Richards Bay
    Age
    47
    Posts
    393
    Thanked: 27

    Thumbs up NGK glow plugs

    +1

    NGK R125-00 excluding vat each at Autozone.

  8. #8
    Join Date
    Apr 2013
    Location
    Debbin
    Age
    37
    Posts
    297
    Thanked: 29

    Default

    Quote Originally Posted by Jaysonjay View Post
    Oh yes I forgot to say, the vehicle is on 140000km and the injectors were done at 100000km
    So its almost run in

    enjoy

Similar Threads

  1. Ranger T6 rear diff lock problems
    By Monkey-D in forum Ford & Mazda
    Replies: 9
    Last Post: 2015/01/19, 08:26 PM
  2. Ranger XLT Spec Upgrade
    By JP in forum Ford & Mazda
    Replies: 23
    Last Post: 2014/11/07, 03:23 PM
  3. Ford & Mazda I love my '06 Ranger!
    By WitBlitz_ZA in forum Ford & Mazda
    Replies: 8
    Last Post: 2013/02/27, 09:33 PM
  4. Ranger vs Mahindra
    By OomD in forum Ford & Mazda
    Replies: 2
    Last Post: 2012/11/04, 06:14 AM
  5. Should we write a Ranger FAQ?
    By Hagu13 in forum Ford & Mazda
    Replies: 6
    Last Post: 2010/06/22, 10:11 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •