Ford Everest Ranger Battery Issues





Results 1 to 8 of 8
  1. #1
    Join Date
    Dec 2009
    Location
    Durban
    Age
    54
    Posts
    7
    Thanked: 0

    Angry Ford Everest Ranger Battery Issues

    I have an Everest 2014 model, had it about three months now, was a demo model that I purchased.
    In the past three months I have had an issue of the battery going flat all of a sudden. Twice it has happened where I have been driving, switched my car off and two or three minutes later when I try and start it the battery is dead.
    I'll jump start it and then it can be fine for weeks / months.
    Anyone else experience a similar problem?
    I have looked on some international forums and there seems to be a problem where the electronic system sometimes doesn't shut down, especially if you haven't locked the vehicle and it does not seem that Ford has come up with a solution yet.
    If this is the case, it still doesn't make sense that the battery would drain in minutes.
    At times I think there is something draining it while driving or the alternator not working properly, but not getting any warning lights.
    Many thanks

  2. #2
    Join Date
    Feb 2015
    Location
    Noordhoek, Cape Town
    Age
    61
    Posts
    6,984
    Thanked: 2454

    Default

    How old is the battery? Could be a short inside the battery?

  3. #3
    Join Date
    Dec 2009
    Location
    Durban
    Age
    54
    Posts
    7
    Thanked: 0

    Default

    Battery is a year old. Had it checked and seems to be fine
    Last edited by Mike Myers; 2015/06/07 at 05:05 PM.

  4. #4
    Join Date
    May 2015
    Location
    Bedfordview
    Age
    70
    Posts
    42
    Thanked: 0

    Default

    Start with the battery and buy a new one (a well-known brand). Batteries can act in inexplicable ways, which you cannot always pick up on testing equipment.

  5. #5
    Join Date
    Dec 2009
    Location
    Durban
    Age
    54
    Posts
    7
    Thanked: 0

    Default

    Thanks MP44

  6. #6
    Join Date
    Sep 2007
    Location
    George
    Age
    40
    Posts
    375
    Thanked: 13

    Default

    I had a similar problem on my jeep. Turned out to be bad connection on the battery terminals. There was some corrosion on the posts. Cleaned up and all sorted.

  7. #7
    Join Date
    Dec 2009
    Location
    Durban
    Age
    54
    Posts
    7
    Thanked: 0

    Default

    Thanks... have checked and all seems good

  8. #8
    Join Date
    Nov 2009
    Location
    Port Elizabeth
    Posts
    353
    Thanked: 14

    Default

    Sometimes the satellite tracking units causes similar problems.
    Might be worth checking it out.
    Basson Kruger.6.5X55,.303SABI,308WM,375H&H SABI. Hilux Revo 2.8GD6 4x4 A

Similar Threads

  1. Ford & Mazda Mazda Drifter Service manual
    By BlomCo in forum Ford & Mazda
    Replies: 6
    Last Post: 2017/02/04, 10:08 AM
  2. Ranger Replacement, the T6
    By Scrat in forum Ford & Mazda
    Replies: 254
    Last Post: 2014/04/24, 06:35 PM
  3. Ford & Mazda Ranger Dual Battery. Help
    By brukutu in forum Ford & Mazda
    Replies: 1
    Last Post: 2014/03/27, 12:09 PM
  4. My Dual Battery Installation in my 2003 Colt 2.8tdi 4x4 double cab
    By Numbnut in forum Camping, Fridges, Accessories
    Replies: 8
    Last Post: 2012/05/17, 01:37 AM
  5. Stoor van battery
    By HendrikG in forum Camping, Fridges, Accessories
    Replies: 8
    Last Post: 2010/09/28, 03:59 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •