Colt Power Loss





Results 1 to 5 of 5

Thread: Colt Power Loss

  1. #1
    Join Date
    Oct 2013
    Location
    Switzerland
    Age
    28
    Posts
    713
    Thanked: 3

    Unhappy Colt Power Loss

    The story begins this morning. Whilst starting the Colt cold, it took 1 more swing than usual to catch and fire up followed by a cloud of white smoke. I know its not allot but these things bother me. Heres a video I made. N.B this is the first start in the morning. https://www.youtube.com/watch?v=3w20RKKcZRA

    Upon driving to work all seemed fine. Cruising at 80KM/h nothing felt wrong or different. I stopped and let the car sit for a few hours to go about my routine, coming back later I had a moment and decided to check oil and water, both seemed fine too and the oil looked fantastic.

    Once the day was over I started the Colt and it fired up with 1 Swing. I was driving back home and realised allot of the low end power which I usually have in abundance was suddenly not there anymore. It revvs up normally to about 1500rpm and then it revvs higher but the speed stays steady (I usually Revv to 2K RPM before shifting), theres no power above 1500rpm.

    I also felt a weird clash and heavy steering wheel rattle when I drove over a speed bump. After the speed bump it went away again though. (Not sure if this has anything to do with the problem.)

    Getting home I popped the hood to take a look and revved her up to 2000RPM and theres a very strange whistling noise coming from the engine bay which was never there before.. I cant identify exactly where its coming from.

    My worst fear is obviously the notorious cracked head...Car has 187 000 trouble free km on the clock though...

    Now, Im aware diagnosing your car with something according to symptoms is like diagnosing yourself online, you either end up diagnosing yourself with Aids or Ebola, so any advice from you guys is much appreciated.
    If power isn't helping, you're not using enough power.

  2. #2
    Join Date
    Aug 2014
    Location
    Pretoria
    Posts
    8
    Thanked: 0

    Default

    What model Colt is this? On a turbo diesel it might be something small like a boost pipe that came loose or burst. The whistle will be the turbo spooling but blowing all the boost out. This will also make your vehicle smoke excessively because the diesel cannot burn efficient without the extra oxygen that the boost creates.

    I would also suggest that you drive the vehicle to past 3000rpm at times. Driving it that slow doesn't allow the turbo to spool up properly and that will get your exhaust gas temperature high.

    Hope you get it sorted

  3. #3
    Join Date
    Oct 2013
    Location
    Switzerland
    Age
    28
    Posts
    713
    Thanked: 3

    Default

    Quote Originally Posted by MacMcD View Post
    What model Colt is this? On a turbo diesel it might be something small like a boost pipe that came loose or burst. The whistle will be the turbo spooling but blowing all the boost out. This will also make your vehicle smoke excessively because the diesel cannot burn efficient without the extra oxygen that the boost creates.

    I would also suggest that you drive the vehicle to past 3000rpm at times. Driving it that slow doesn't allow the turbo to spool up properly and that will get your exhaust gas temperature high.

    Hope you get it sorted
    Thank you, yeah it is the 2800tdi. Ill check out the boost pipe, I figured it was something of the sort. Thanks for the input
    If power isn't helping, you're not using enough power.

  4. #4
    Join Date
    May 2013
    Location
    Jeffreys Bay
    Age
    39
    Posts
    366
    Thanked: 11

    Default

    I had a similar problem. Thread is somewhere on the forum. Turned out to be the turbo. I bought a new one, replaced the old one and bob's your uncle. I must say....... I will NEVER do it myself again.......
    A clean 4x4 is a sign of a sick mind.
    Colt Clubcab 2800 TDI 4x4 - SAC EGT & Boost combo, 180watt lightbar (probably illegal) GET IN, SIT DOWN
    SHUT UP, & HANG ON
    Suzuki GSXR1100 - net vir die teer.... - Sold
    BB - Restored

    Previous:
    Toyota 3.0KZ-TE SC (you will be missed)
    Pajero 3.5 V6 (Die dors ene)

  5. #5
    Join Date
    Feb 2010
    Location
    Malmesbury
    Age
    60
    Posts
    985
    Thanked: 116

    Default

    Quote Originally Posted by JJjbay View Post
    I had a similar problem. Thread is somewhere on the forum. Turned out to be the turbo. I bought a new one, replaced the old one and bob's your uncle. I must say....... I will NEVER do it myself again.......
    why not

    Colt clubcab 2.8tdi 4x4 2005
    Ford Fiesta 1.4i (SWAMBO]
    jurgens off road trailor xt 140
    opel corsa 1.7 dti 2006

Similar Threads

  1. Bigger Tyre = Power Loss = Worth it?
    By Kappie in forum Suzuki
    Replies: 46
    Last Post: 2017/06/02, 12:28 AM
  2. Power loss again
    By gerrit123 in forum Nissan
    Replies: 12
    Last Post: 2013/10/16, 09:16 AM
  3. 2SO- 300 TDI - Loss of power
    By RossJ in forum Land Rover
    Replies: 69
    Last Post: 2012/04/25, 07:42 PM
  4. Help! Sudden power loss Triton 3.2DiD
    By tritontitan in forum Mitsubishi
    Replies: 17
    Last Post: 2011/08/03, 04:53 PM
  5. Cherokee 4.0L Sport 1998 - Random loss of electrical power
    By ibouwer in forum Jeep
    Replies: 12
    Last Post: 2011/02/04, 10:55 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •