Ford & Mazda Alternator & Sediment Light - 2001 Drifter B2500 TDi 4x4





Results 1 to 4 of 4
  1. #1
    Join Date
    May 2013
    Location
    Cape Town
    Age
    44
    Posts
    12
    Thanked: 0

    Default Alternator & Sediment Light - 2001 Drifter B2500 TDi 4x4

    Hi All,

    A little back I had the head of my bakkie replaced due to overheating (and after changing the radiator). Since then there seems to be some sort of electrical problem.

    Over the weekend it appeared that the alternator was not charging (or at one stage over-charging) so yesterday, I replaced the regulator and the fan belts (just to be on the safe side). Testing the alternator (using a multi-meter) it seems to working as required.

    However, the Alternator and Sediment Filter lights are constantly on. This happened just after the replacement of the head but seemed to solve it self i.e. the lights went off. The fuel filter is less than 5,000km old.

    Now they are back again.

    Also, this morning the rev counter & spedometer went to max when turing the key on and stayed there. Again, it seemed to solve itself a few min. later. To me this indicates some sort of earthage problem.

    Any suggestions as to why these lights are on and where I should start investigating..

    Any help will be appreciated.

    Thanx
    DW
    Last edited by dwd_za; 2013/08/20 at 11:36 AM.

  2. #2
    Join Date
    Sep 2007
    Location
    Pretoria
    Age
    51
    Posts
    145
    Thanked: 0

    Default

    HI, had a similar problem, the lights came on barely visible while driving and increased slightly in brightness when revs when up, popping sounds on the radio, everything going off when the brights were engaged, immobiliser doing strange things. I fixed my cables going into the battery connectors, plus and negative, seems the crimping comes loose after years and does not make a decent connection, worth a try, hope it will solve your issue. Havent had the problem again. Traced it to the plus terminal connector, all electrics was dead, opened the bonnet and by chance just pushed the cable and everything came to life. Somewhere there is a thread about an earth in the wiring loom close to the firewall that has spot welding which comes loose also.
    2000 Drifter SLX DC 2.5 TD

  3. #3
    Join Date
    Mar 2013
    Location
    Brakpan
    Age
    36
    Posts
    10
    Thanked: 0

    Default

    Check the earth cable at the back of the head that goes to the firewall, maybe they didn't fasten it properly

  4. #4
    Join Date
    May 2013
    Location
    Cape Town
    Age
    44
    Posts
    12
    Thanked: 0

    Default

    Hi,

    Been a while, so thought I would just provide an update.

    I tried the above suggestions with no luck. Then out of the blue the lights went off and is still off. So I don't know what happened and why....

    Thanx none-the-less for the advice though

    DW

Similar Threads

  1. Brakkeduine 4x4 Trail near PE.
    By Big Hilux in forum Eastern Cape
    Replies: 16
    Last Post: 2017/11/13, 07:56 AM
  2. Females
    By 4x4 in forum General 4x4 Discussion
    Replies: 146
    Last Post: 2013/09/04, 03:30 PM
  3. Replies: 12
    Last Post: 2007/07/24, 10:10 AM
  4. Another bash at The Rocky Mounatin 4x4 Trail
    By Big Hilux in forum Eastern Cape
    Replies: 5
    Last Post: 2007/02/20, 01:19 PM
  5. Search Engines
    By benhur in forum General 4x4 Discussion
    Replies: 3
    Last Post: 2006/09/14, 09:42 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •