Results 1 to 10 of 10
  1. #1
    Join Date
    Sep 2010
    Location
    Muldersdrift
    Age
    55
    Posts
    15
    Thanked: 0

    Default Def 110 TDI Power Loss of a different kind - Please help.

    Hi Everyone.

    I have a Def 110 TDI 97 with about 450 000Kms on the clock, now having no power.

    History:
    2011(Botswana Maun):
    Gear box was rebuilt and a second hand casing replaced.
    Transfer box rebuilt at the same time.
    Drive back to JHB +/_ 1600kms. All systems good lot of power and everything working.
    I take vehicle to my mechanic for a vehicle check. I have work done on other components. I'e brakes, fuel pump and something else.
    Get vehicle back. It feels sluggish and no power. A week later i cant take it anymore and go back to Mech. We go on a test driver up a long hill. No power. He says he need to do some tests, Ie Injectors, Turbo and timing belt. I say okay but need the LR for a trip. Mech tells me its fine to go on trip. I do so but freak because it so slow. Get back to Mech.
    His Diagnosis:
    Possibly my gearbox is a Disco box. That's why no power. He now has to source a swap out for me.
    Question to the Community:
    I drove back from Botswana with lots of power for over a month without any problems. Can this be that I have a disco box and this will cause power loss?
    How if I had power can this happen if I have the incorrect gearbox?

    To me I would have thought the timing belt was fitted incorrectly?
    The Turbo might be faulty?
    Injectors might be dirty or need replacing?

    Please help and advise. Should I find another mech?

    Thank you.

  2. #2
    Join Date
    Jan 2009
    Location
    Pretoria
    Age
    37
    Posts
    9,381
    Thanked: 103

    Default

    Take it to a different mechanic for 2nd opinion
    Range Rover Big Body 5.0 V8 Supercharged
    Land Rover Defender 110 CSW Puma
    Land Rover Defender 110 V8 Game viewer
    Land Rover Defender 100 PU V8
    Land Rover Freelander II SD4
    Jaguar XJS V12

  3. #3
    Join Date
    Nov 2006
    Location
    Edenglen
    Age
    50
    Posts
    2,462
    Thanked: 243

    Default

    Get a second opinion. Sounds to me like the timing is set incorrectly, or the fuel pump is tired. Does it smoke a lot? Have you checked the turbo?
    Erin Bosch (082 342 1909)
    4xfagger no. GP0048



    2007 Volkswagen T5 4Motion

  4. #4
    Join Date
    Sep 2010
    Location
    Muldersdrift
    Age
    55
    Posts
    15
    Thanked: 0

    Default

    It smokes a lot on pull off. Black smoke. Thank you I will get a 2nd opinion.

  5. #5
    Join Date
    Sep 2010
    Location
    Muldersdrift
    Age
    55
    Posts
    15
    Thanked: 0

    Default

    Thank you. Yep that was I was thinking. I don't want to go through unnecessary expense.

  6. #6
    Join Date
    Nov 2006
    Location
    Cape Town
    Age
    73
    Posts
    2,235
    Thanked: 1

    Default

    A factor that can be overlooked on the TDi is the tension on the accelrerator cable. Check that the last section of the cable has no slack in it. There is a knurled adjustment wheel - after battling with my TDi on a long trip , I discovered there was slack and the adjustment rejuvenated the old bus.

  7. #7
    Join Date
    Sep 2010
    Location
    Muldersdrift
    Age
    55
    Posts
    15
    Thanked: 0

    Default

    Okay didn't think about the accelerator adjuster. Will tell my mech to look into that.

  8. #8
    Join Date
    Aug 2011
    Location
    Hunters Close, Port Elizabeth
    Age
    52
    Posts
    5,497
    Thanked: 77

    Default

    checkout landyworx look in the land rover section several threads about them....

    here found their info LANDYWORX - Peter and Walter 011 781 0020

    everyone raves about them definitely take it too them b4 spending more money
    Last edited by JediNAfrica; 2012/11/19 at 08:41 PM.
    Luke aka Jedi

    1954 Landy Rover Series 1 86"- Rambling Rose
    Best company slogan: Cherrybomb performance exhaust, Disturbing the peace since 1968



  9. #9
    Join Date
    Nov 2006
    Location
    Edenglen
    Age
    50
    Posts
    2,462
    Thanked: 243

    Default

    Quote Originally Posted by Bushwacker View Post
    It smokes a lot on pull off. Black smoke. Thank you I will get a 2nd opinion.
    Had the same issue with mine - lots of smoke on starting and pull off, and loss of power - the timing belt was one tooth out.
    Erin Bosch (082 342 1909)
    4xfagger no. GP0048



    2007 Volkswagen T5 4Motion

  10. #10
    Join Date
    Oct 2010
    Location
    Pretoria and Zürich/Switzerland
    Age
    67
    Posts
    7,040
    Thanked: 486

    Default

    Hi bushwacker

    fairly close to you, you can also go to Landyonline ([email protected]), they have the Snap-on pump timing tool, which allows them to set the pump timing dynamically, which means that it will be 100% spot on.

    If that turns out ok, then the front cover must come off and the timing belt must be checked for proper fitment, i.e. cam timing ok.

    The black smoke on take off has nothing to do with the turbo, that is set by the adjustment screw under the blanking plug on top of the pump.

    Hope this helps!
    George Bosch
    2003 RangeRover Vogue 3.0 Td6 (Mine) / 2005 LR Disco3 TDV6 S (Swambo's) / 1998 Disco1 Tdi ES (Sold) / And some more serious stuff

    Distributor for:
    DEFAProjectaSignature.png


    Special offers for 4X4community forum members on CTEK! Send PM with your email address for details

Similar Threads

  1. Bigger Tyre = Power Loss = Worth it?
    By Kappie in forum Suzuki
    Replies: 46
    Last Post: 2017/06/02, 12:28 AM
  2. Overland Journal Portable 12V Fridge Review
    By ChrisH in forum Camping, Fridges, Accessories
    Replies: 20
    Last Post: 2011/11/30, 11:26 AM
  3. CPT - JHB Def 110 with crabs
    By mdickerson in forum Land Rover
    Replies: 6
    Last Post: 2010/10/02, 01:21 PM
  4. PRO'S & CON'S 110 CLUB CUB/130 TDi
    By 10135556 in forum Land Rover
    Replies: 5
    Last Post: 2009/04/17, 03:47 PM
  5. Strange noise Def. 110 TDI, Please Help??
    By brucepolks in forum Land Rover
    Replies: 5
    Last Post: 2008/12/04, 07:43 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •