" Check engine " light ?





Results 1 to 11 of 11
  1. #1
    Join Date
    Aug 2008
    Location
    Rangeview Krugersdorp
    Age
    70
    Posts
    6,280
    Thanked: 1038

    Default " Check engine " light ?

    Anybody able to plug in my Tucson on the West Rand to a scanguage?
    Went off this morning and ten minutes on the highway the light came on. No noticeable change in anything. Would love to know what's possibly wrong before anyone starts looking for me and charges a fortune for the wrong 'fix'
    Anywhere West and anytime .
    thanks,
    Duncan
    There is no task too simple for some people to complicate !



    Chev Aveo and Atos and Polo.

  2. #2
    Join Date
    Jan 2012
    Location
    Stillbaai
    Age
    64
    Posts
    12
    Thanked: 0

    Default

    Hi I Have got a terracan same happend to me but the ligh went out again this happend 2 weeks ago and did not come back, funny thing was the speedo behaved like a rev counter but after switching off and resetting the imobiliser all was back to normal

  3. #3
    Join Date
    Aug 2008
    Location
    Rangeview Krugersdorp
    Age
    70
    Posts
    6,280
    Thanked: 1038

    Default

    Bump please
    There is no task too simple for some people to complicate !



    Chev Aveo and Atos and Polo.

  4. #4
    Join Date
    May 2007
    Location
    Kraaifontein, Cape Town
    Age
    61
    Posts
    2,711
    Thanked: 9

    Default

    I'm too far south mate can't help you
    Morton the " BEAST " Berg
    3 Skid plates;75mm lift;275/70/16 Maxxis MT's;Merrit 16”rims;Maxe spots+ night breakers on all lights; Solace protection;TJM snorkel;TJM XGS shocks;TJM coils+Bellows; Maniac front & rear steel bumpers;Spare wheel and 3x Jerry can carriers;Rock sliders;Side awning;Front Runner roof rack; Dual batt system;Procool fridge/freezer;2xGarmin;clinometer;Twin free flow exhaust,Fini comp; ARB independent Airlockers F&B; Winch; Drawer Sys;50Lt Water tank;VHF&29Mhz(2)radios; 8x ss Fish road holders; Safety whip&flag.Future mods,Viper V10or Lex V8 Lumina 6lt

  5. #5
    Join Date
    Aug 2008
    Location
    Rangeview Krugersdorp
    Age
    70
    Posts
    6,280
    Thanked: 1038

    Default

    Thanks, still struggling. Got a P0403 error message, they blocked off the EGR valve for R1k, drove 40 k's and the light came back on
    Going to scan again tomorrow……….
    There is no task too simple for some people to complicate !



    Chev Aveo and Atos and Polo.

  6. #6
    Join Date
    May 2007
    Location
    Kraaifontein, Cape Town
    Age
    61
    Posts
    2,711
    Thanked: 9

    Default

    I'll check tomorrow night what this code is if I have it and let you know bud. Outa town now
    Morton the " BEAST " Berg
    3 Skid plates;75mm lift;275/70/16 Maxxis MT's;Merrit 16”rims;Maxe spots+ night breakers on all lights; Solace protection;TJM snorkel;TJM XGS shocks;TJM coils+Bellows; Maniac front & rear steel bumpers;Spare wheel and 3x Jerry can carriers;Rock sliders;Side awning;Front Runner roof rack; Dual batt system;Procool fridge/freezer;2xGarmin;clinometer;Twin free flow exhaust,Fini comp; ARB independent Airlockers F&B; Winch; Drawer Sys;50Lt Water tank;VHF&29Mhz(2)radios; 8x ss Fish road holders; Safety whip&flag.Future mods,Viper V10or Lex V8 Lumina 6lt

  7. #7
    Join Date
    May 2007
    Location
    Kraaifontein, Cape Town
    Age
    61
    Posts
    2,711
    Thanked: 9

    Default

    Hi Duncang, looked in my codes book and found the code P0403 which say Fault Location is "Exhaust Gas Recirculation (EGR) - circuit malfunction" and Probable cause is "Wiring, EGR solenoid, ECM" so in my terms check your wiring by EGR could be loose or corroded. Hope this helps
    Morton the " BEAST " Berg
    3 Skid plates;75mm lift;275/70/16 Maxxis MT's;Merrit 16”rims;Maxe spots+ night breakers on all lights; Solace protection;TJM snorkel;TJM XGS shocks;TJM coils+Bellows; Maniac front & rear steel bumpers;Spare wheel and 3x Jerry can carriers;Rock sliders;Side awning;Front Runner roof rack; Dual batt system;Procool fridge/freezer;2xGarmin;clinometer;Twin free flow exhaust,Fini comp; ARB independent Airlockers F&B; Winch; Drawer Sys;50Lt Water tank;VHF&29Mhz(2)radios; 8x ss Fish road holders; Safety whip&flag.Future mods,Viper V10or Lex V8 Lumina 6lt

  8. #8
    Join Date
    Oct 2006
    Location
    CAPE TOWN ,SOUTH AFRICA
    Age
    69
    Posts
    14,080
    Thanked: 530

    Default

    hey Morton, what do you know about warning lights now. MAF Yes, maybe

    Now when are we going to see you on a trail.?

  9. #9
    Join Date
    Aug 2008
    Location
    Rangeview Krugersdorp
    Age
    70
    Posts
    6,280
    Thanked: 1038

    Default

    Thanks, the car is with Hyundai in desperation. They have already told me they are putting in a new EGR valve at 4K ! So it could be just a loose wire…...
    There is no task too simple for some people to complicate !



    Chev Aveo and Atos and Polo.

  10. #10
    Join Date
    Aug 2008
    Location
    Rangeview Krugersdorp
    Age
    70
    Posts
    6,280
    Thanked: 1038

    Default

    Back from Hyundai Friday afternoon. Done 60 K's and the light is still off, but…..
    Still rough acceleration and very noisy foot foot sound which is very loud if I open the airfilter cover ? As if the noise is coming from the exhaust and back down the inlet manifold backwards to the filter Replaced the 3mm vacuum hose from the actuator and accelerator sensor as they seemed to be very loose. Could not buy 4mm yesterday, that piece is also loose from EGR valve to Actuator.
    No vacuum or blowing in 4mm tube at idle or high revs? Maybe loose where it disappears under the fuel pump area?
    Motor is fine, imjectors and compression tops.
    Any ideas?
    There is no task too simple for some people to complicate !



    Chev Aveo and Atos and Polo.

  11. #11
    Join Date
    Aug 2008
    Location
    Rangeview Krugersdorp
    Age
    70
    Posts
    6,280
    Thanked: 1038

    Default

    Anyone got a friend at a nearby Hyundai branch ?
    There is no task too simple for some people to complicate !



    Chev Aveo and Atos and Polo.

Similar Threads

  1. WJ 2.7 CRD Maintenance
    By wtrlan in forum Jeep
    Replies: 240
    Last Post: 2018/04/19, 07:20 AM
  2. antifreeze
    By Landyluvver in forum Land Rover
    Replies: 25
    Last Post: 2012/08/13, 12:29 PM
  3. engine management light
    By fos in forum Toyota
    Replies: 13
    Last Post: 2011/12/14, 09:56 PM
  4. Grand Cherokee Error code
    By Nick47 in forum Jeep
    Replies: 4
    Last Post: 2010/08/30, 01:28 PM
  5. Td5 Engine warning light coming on!!!
    By Naks in forum Land Rover
    Replies: 4
    Last Post: 2010/07/19, 09:19 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •