Search Results - 4x4 Community Forum





Search:

Type: Posts; User: KZN; Keyword(s):

Search: Search took 0.01 seconds.

  1. Replies
    8,669
    Views
    969,628

    Re: What have you done with your Discovery today?

    A loosely tightened positive terminal on the battery after a service also caused those faults to come up for me ....
  2. Thread: Bird ID

    by KZN
    Replies
    16
    Views
    1,463

    Re: Bird ID

    Hi Peet

    Wattled Starling
  3. Replies
    50
    Views
    2,921

    Discovery 3 Re: Disco 3 bongs _ I need help

    Check the brake light bulbs themselves.....need to be genuine Land Rover bulbs, any other bulbs have been known to throw all sorts of fault codes out
  4. Discovery 3 Re: Disco 3 Average Speed & Consumption not working

    Hi Gairezi. When last did you reset the avg consumption timer or the odo? (button on the indicator stick) If it hasn't been done for a while your avg consumption and speed hardly change at all.
  5. Replies
    1,448
    Views
    141,715

    Sticky: Re: Bird Identification

    I think this is a Cape Wagtail that has somehow lost its tail feathers.
  6. Replies
    243
    Views
    40,072

    Re: ZF Automatic Transmission - Oil Change Special

    Peter Suckling - Disco 3 - Durban
  7. Thread: tdv6 oil light

    by KZN
    Replies
    19
    Views
    2,163

    Discovery 3 Re: tdv6 oil light

    Noticed the exact same thing this weekend on mine . Please do let us know Walter's feedback.
  8. Replies
    4
    Views
    627

    Re: Disco 3 Air Mattress

    Hi Aquiva

    Just did a trip down to Knysna. Used an Intex Double bed size blow up . Fits in perfectly.(sory no pics)
  9. Replies
    54
    Views
    24,228

    Discovery 2: Hi Greg I am normally just a lurker...

    Hi Greg

    I am normally just a lurker here,however your symptons are so similar to what I experienced last year year with my disco (2001 TD5 250 000kms) that I thought I should add my 2c .Had the...
Results 1 to 9 of 9