Cherokee Power loss problem at 2000 rpm??




Results 1 to 12 of 12
  1. #1
    Join Date
    Nov 2009
    Location
    Centurion
    Age
    34
    Posts
    8
    Thanked: 0

    Exclamation Power loss problem at 2000 rpm??

    Good day all,

    I am new to the forum and unfortunately have to share a problem and ask for advise and opinions in my first post....

    I have just bought a second hand '98 Cherokee 2.5 turbo diesel with 156 000 on the clock, all the test drives and inspections of the car was all good, I bought the car knowing that it needs a service and a good look over, but she was going like a boeing!

    I spent all of last weekend cleaning and washing the car, including the engine bay, and think that this is where my problem started,

    I took the car for a drive around the block and noticed right away that the power has gone, almost feels like the car has been limited, car feels normal until she gets to 2000 rpm and then just struggles to go... I have done allot of reading on the net and there seems to be a couple of things that could be the problem,

    1. mass air flow sensor
    2. no. 1 injector sensor got wet
    3. turbo pipes sucking closed

    Gents I really need to get to the bottom of this problem, this is not how I imaged my first week with my new baby would be, almost feels like the dream is quickly turning into a nightmare... has anyone had a smiler problem, could anyone point me in the right direction?

    Thanks in advance,

    Fugs.

  2. #2
    Join Date
    Mar 2009
    Location
    Port Elizabeth
    Age
    38
    Posts
    822
    Thanked: 0

    Default

    It seems that the vehicle has gone into limp mode, is any of the engine lights on?

    Try disconnecting the battery for about 5 minutes, and then take it for a drive.

    Hope this helps.
    Isuzu KB300 D-teq auto 4x4 D/Cab
    1996 Nissan Patrol.........To be continued!!

    Andre Thuynsma

  3. #3
    Join Date
    Jan 2009
    Location
    JHB
    Age
    40
    Posts
    63
    Thanked: 0

    Default

    Bud, mine just did the same today but i am getting heavy black smoke out the exhaust pipe!! Got a sinking feeling that the turbo has blown..

  4. #4
    Join Date
    Dec 2008
    Location
    Vaal Dam & Alberton
    Age
    66
    Posts
    309
    Thanked: 0

    Default

    Try priming the diesel filter, the KJ's develop an airlock in the filter.

  5. #5
    Join Date
    Nov 2009
    Location
    Centurion
    Age
    34
    Posts
    8
    Thanked: 0

    Default

    Thanks for the reply's gents, I will try anything at this moment...

    None of the engine lights are on but will disconnect the battery to see if it it helps, Thanks Jabu Jeep.

    Selwyn, could you explain exactly how to prime the filter?

    When I have some more time have I got some stories to share about this experience, maybe I should wright a book.....

  6. #6
    Join Date
    May 2009
    Location
    Cape Town
    Age
    30
    Posts
    152
    Thanked: 0

    Default

    Quote Originally Posted by Selwyn View Post
    Try priming the diesel filter, the KJ's develop an airlock in the filter.
    x2
    my xj diesel primer pump had an airlock and it had me floored for 2 days

  7. #7
    Dieselbob Guest

    Default

    Hi matey (fugs) , did you get to the bottom of this problem as i have encountered the same with my xj and am at a bit of a loss ??

    Cheers.
    Bob.

  8. #8
    Join Date
    Nov 2009
    Location
    Centurion
    Age
    34
    Posts
    8
    Thanked: 0

    Default

    Bob, a long story short. Yes, we have sorted out the problem...

    It was the mass airflow censor! New one from the stealers R4300-00 got a second hand one for R285-00 and all is good.....

  9. #9
    Join Date
    Jan 2010
    Location
    Retreat
    Age
    55
    Posts
    3
    Thanked: 0

    Default

    Fugs, glad you got yours sorted. I also bought a 2004 2.4sport in November last year. Since then the engine light has been coming on quite regularly. Took it back to the dealer and comes back with light off. Noticed that after I fill up, the light comes on after a long drive. Took it to Jeep dealer twice and both times the diagnostics pointed to the O2 sensor on the exhaust manifold. Had the sensor replced but it still happens. It's getting heavy on gas with the light on. I'm at my wits end as to what to do now. Any ideas out there?

  10. #10
    Join Date
    Dec 2006
    Location
    Cape Town, Otjiwarongo
    Age
    40
    Posts
    2,644
    Thanked: 3

    Default

    Quote Originally Posted by Tecsas View Post
    Fugs, glad you got yours sorted. I also bought a 2004 2.4sport in November last year. Since then the engine light has been coming on quite regularly. Took it back to the dealer and comes back with light off. Noticed that after I fill up, the light comes on after a long drive. Took it to Jeep dealer twice and both times the diagnostics pointed to the O2 sensor on the exhaust manifold. Had the sensor replced but it still happens. It's getting heavy on gas with the light on. I'm at my wits end as to what to do now. Any ideas out there?
    Sounds like the dealers don't know that they are talking about. have a look for Jeep specialists (that know diesels) in your area. where are you based?
    2002 Nissan Patrol 4.2Td. Body lift, 5cm OME lift 33inch Cooper SST, Burnco bumpers.

    Platkar:2002 BMW M5, 2002 M Coupe and 1985 635csi
    SWAMBO: BMW X5 3.0D
    Talk softly, carry a BIG stick
    Ex: Jeep Cherokee XJ 2.5Td

  11. #11
    Join Date
    Jan 2010
    Location
    Retreat
    Age
    55
    Posts
    3
    Thanked: 0

    Default

    Hey Biggles, I've got the petrol version. I live in Retreat and bought the vehicle in Paarden Eisland. I was told to take the van in tomorrow morning and they will be sending it a different "specialist". Will have to see what happens and will keep you posted. Thanx.

  12. #12
    Join Date
    Dec 2006
    Location
    Cape Town, Otjiwarongo
    Age
    40
    Posts
    2,644
    Thanked: 3

    Default

    Quote Originally Posted by Tecsas View Post
    Hey Biggles, I've got the petrol version. I live in Retreat and bought the vehicle in Paarden Eisland. I was told to take the van in tomorrow morning and they will be sending it a different "specialist". Will have to see what happens and will keep you posted. Thanx.
    Oh, did not know they made a petrol 2.4l!! Well then any jeep specialist should be able to help. Good luck.
    2002 Nissan Patrol 4.2Td. Body lift, 5cm OME lift 33inch Cooper SST, Burnco bumpers.

    Platkar:2002 BMW M5, 2002 M Coupe and 1985 635csi
    SWAMBO: BMW X5 3.0D
    Talk softly, carry a BIG stick
    Ex: Jeep Cherokee XJ 2.5Td

Similar Threads

  1. Defender Puma - Peculiar Power loss
    By Landy_Man in forum Land Rover
    Replies: 38
    Last Post: 2009/11/18, 09:44 AM
  2. Eskom Power shortages
    By Fabfender in forum Alternative Energy Solutions
    Replies: 33
    Last Post: 2008/11/16, 05:44 PM
  3. 276C power on problem
    By oulouis in forum GPS & Mapping
    Replies: 1
    Last Post: 2008/07/14, 10:17 AM
  4. Replies: 6
    Last Post: 2008/03/28, 06:19 PM
  5. Where has all my V8's power gone???
    By Barto in forum Vehicle & Technical Chat - General
    Replies: 7
    Last Post: 2007/12/29, 03:53 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •